cursor moves right no matter if there is some text or not

RESOLVED FIXED

Status

RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: irakli, Unassigned)

Tracking

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090122 Ubuntu/8.10 (intrepid) Shiretoko/3.1b3pre Ubiquity/0.2pre5
Build Identifier: 

When you open some file pressing right(->) button will move cursor to the right no matter if there any character on the right or not, while I would expect that cursor will jump to the next line if there is no more characters on the right of the cursor. It makes so hard to get if there is white-space on the end of the file or not.

Reproducible: Always

Steps to Reproduce:
1. open editor
2. press end
3. pres right
Actual Results:  
cursor moves right

Expected Results:  
as there is no characters on the right of the line it should jump to the next one

Firefox 3.1
the same problem happens with the mouse click, you can basically click anywhere and the cursor will go there. Should this case be covered by a separated bug, or is it the same problem (editor should enforce line limits)?
oh, regarding my previous comment, the mouse case is described on bug 478391

Comment 3

10 years ago
This is apparently a feature, not a bug: http://hg.mozilla.org/labs/bespin/rev/14ae0b4af625
the strictline mode described on that changeset does not work for me (although I have tested on bespin site only, not locally)

Comment 5

10 years ago
We haven't deployed the latest code yet.... as soon as we do strictlines will work for you!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Version: unspecified → Trunk
This is a mass migration from Mozilla Labs :: Bespin to Bespin :: General.

This bug likely still needs to be triaged and categorized.
Component: Bespin → General
Product: Mozilla Labs → Bespin
QA Contact: bespin → general
Target Milestone: -- → ---
You need to log in before you can comment on or make changes to this bug.