Crash after accepting "Connection to server news.sunsite.dk timed out" message twice [@ nsCOMPtr_base::assign_with_AddRef]

RESOLVED WORKSFORME

Status

MailNews Core
Networking: NNTP
--
critical
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Henrik Larsson, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(4 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6 (.NET CLR 3.5.30729)
Build Identifier: 2.0.0.19 (20081209)

Lately I have seen the following message a lot:
"Connection to server news.sunsite.dk timed out"

This is strange, because every time Thunderbird starts up, it has no problem getting the new messages from the news server. I have been looking at a packet capture, and found no problems with the connection. So the "Connection time out" message could be misleading.

But if I click OK at the above message, it will come back after some time again. If I click OK the second time, Thunderbird will crash or just not show any news message text at all. This is also strange, because the messages is marked for offline view, so I suspect that some component of Thunderbird is crashing.

You can close the program using normal Windows "red cross" in the upper right corner, but if I check the taskmanager after this, thunderbird.exe is still running. So after the above "connection timed out" message twice, Thunderbird is not able to close down corretly.

Reproducible: Sometimes

Steps to Reproduce:
1. Wait for "Connection time out" message and click OK
2. Wait for another "Connection time out" message and click OK again
3. Try to read a news message
Actual Results:  
Thunderbird becomes unresposive to some actions. Unable to read news messages. Unable to close down properly.

Expected Results:  
Thunderbird should not crash, even if it thinks that the "Connection timed out".
(Reporter)

Comment 1

9 years ago
Created attachment 362291 [details]
Thunderbird NNTP log with severity 5
(Reporter)

Comment 2

9 years ago
Created attachment 362293 [details]
DrWtsn32 log

A DrWtsn32 log. Manually debuging thunderbird.exe after it should have shut down correctly.
(Reporter)

Comment 3

9 years ago
Created attachment 362294 [details]
User dump file

User dump file for DrWtsn32 log in attachment ID 362293
When it crashes does talckback show up ? if so could you give us crash IDs ?
Component: General → Networking: News
Product: Thunderbird → MailNews Core
QA Contact: general → networking.news
Version: unspecified → 1.8 Branch
(Reporter)

Comment 5

9 years ago
It did so some times, but I was not clever enough to write down the crash IDs. They were uploaded using the same e-mail address as was used to create this bug report.
(In reply to comment #5)
> It did so some times, but I was not clever enough to write down the crash IDs.

Unfortunatly - can't search with the email ... can't find it. But if you launch talkcback by itself you will be able to see the ID.
Connection time out is caused by the call to read from a socket timing out, if I am not mistaken.

It sounds like the connection is timing out in an inopportune moment. Judging from the logs, it looks like fetching newsrc data is where the problems are at. A crash stack with symbols would be most useful here.
(Reporter)

Comment 8

9 years ago
Here are some talkback IDs:
TB52902091Z
TB52933487H
TB52934911E
The first two stack crashes seem to my untrained eyes to be bad, but the third one seems close to the stack from bug 433888, which would imply that m_channelListener is being set to a non-zero value that is not a valid pointer.

Most definitely a crasher now, the only question I have remaining is whether or not this is a dupe of bug 433888.
Severity: normal → critical
Keywords: crash
Summary: Crash or unresponsive after accepting "Connection to server news.sunsite.dk timed out" message twice → Crash after accepting "Connection to server news.sunsite.dk timed out" message twice
(Reporter)

Comment 10

9 years ago
And another Talkback ID:
TB52941503W
(In reply to comment #10)
> And another Talkback ID:
> TB52941503W

Thanks Henrik. Does this also happens with the recent builds from 3.0beta , would you mind backing up your profile and trying with a build from http://www.mozillamessaging.com/en-US/thunderbird/early_releases/downloads.php ?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 12

9 years ago
Hi Ludovic

Using Thunderbird 3 beta 1 (US) I am not able to reproduce the problem.

The progress bar at the bottom right corner is not showing me any connection problems as well.

Comment 13

9 years ago
Incident ID: 52902091
Stack Signature	 0x00000000 5cb78419
Product ID	Thunderbird2
Build ID	2008120920

0x00000000
nsCOMPtr_base::~nsCOMPtr_base  [mozilla/xpcom/build/nsCOMPtr.cpp, line 82]
nsInputStreamPump::OnStateStop  [mozilla/netwerk/base/src/nsInputStreamPump.cpp, line 564]
0x02a00a88
nsNNTPProtocol::`vftable'
nsNNTPProtocol::AddRef
0x7e05e90c

Incident ID: 52933487
Product ID	Thunderbird2
Build ID	2008120920
nsFolderCompactState::~nsFolderCompactState  [mozilla/mailnews/base/src/nsMsgFolderCompactor.cpp, line 90]
nsInputStreamPump::OnStateStop  [mozilla/netwerk/base/src/nsInputStreamPump.cpp, line 564]
0x02a8b508

Incident ID: 52934911
Product ID	Thunderbird2
Build ID	2008120920
0x02aeef38
nsNNTPProtocol::CloseSocket  [mozilla/mailnews/news/src/nsNNTPProtocol.cpp, line 5301]
nsNNTPProtocol::OnStopRequest  [mozilla/mailnews/news/src/nsNNTPProtocol.cpp, line 1237]
nsInputStreamPump::OnStateStop  [mozilla/netwerk/base/src/nsInputStreamPump.cpp, line 564]
0x040008e0
nsNNTPProtocol::`vftable'
nsNNTPProtocol::AddRef
0x7e05e90c
0x17202552
(Reporter)

Comment 14

9 years ago
Yet another talkback ID with Thunderbird 2.0.0.19:
TB53376579Y

Comment 15

9 years ago
xref Bug 445372 -  crash [@ nsCOMPtr_base::assign_with_AddRef]
Summary: Crash after accepting "Connection to server news.sunsite.dk timed out" message twice → Crash after accepting "Connection to server news.sunsite.dk timed out" message twice [@ nsCOMPtr_base::assign_with_AddRef]
(Reporter)

Comment 16

9 years ago
I have now in two different occasions discovered that the "Connection to server news.sunsite.dk timed out" message appeared during compacting of one specific newsgroup.

Hope that this new information could lead to resolving this issue.
(Reporter)

Comment 17

8 years ago
I'm now certain that this is due to compacting. I see a specific newsgroup is being compacted and then the message "Connection to server
news.sunsite.dk timed out" appear.

If I shutdown Thunderbird and restart it, the same issue occur after reading the same newsgroup again.

I see that files named nstmp-1, nstmp-2 and etc. is created in the "Profiles\<profilename>\News\news.sunsite.dk" folder.

If I go ahead and delete the .msg file for the newsgroup in question, the "timed out" error goes away for a while.

In some time the error will not appear, but at some point it returns with another newsgroup.

I have tried to attach a .msg file from a time where the issue occured.
(Reporter)

Comment 18

8 years ago
Created attachment 395136 [details]
A .msg file from a point when there is a compacting issue

Updated

8 years ago
Blocks: 433888

Comment 19

8 years ago
(In reply to comment #17)
> I'm now certain that this is due to compacting. I see a specific newsgroup is
> being compacted and then the message "Connection to server
> news.sunsite.dk timed out" appear.

Interesting.

Henrik, Bradley, can  you reproduce with version 3?
 http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
 backup your profile before using
Haven't had this happen recently (on 3.0.x)
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsCOMPtr_base::assign_with_AddRef]
You need to log in before you can comment on or make changes to this bug.