anisearch.de - Drag & Drop image to desktop saves as jpeg even if HTML is sent

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
German
--
minor
RESOLVED WORKSFORME
9 years ago
3 years ago

People

(Reporter: Hero Wanders, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6 (.NET CLR 3.5.30729)

When drag&dropping a certain image onto the desktop not the image is saved but a new query is made which returns a HTML page. Despite of this the file is saved as jpeg-File. As far as I can see the headers returned by the server are correct. I added the headers sent when dragging the image to the desktop.
The content of the created jpeg is the redirection page which comes up when no referer is sent while trying to open such a wallpaper on that site.


Reproducible: Always

Steps to Reproduce:
0. Make sure Javascript is enabled!
1. Visit http://anisearch.de/?page=wallpapers&id=382&select=21456&site=2
2. Click on the image below 'Wallpaper-Details: Ergo Proxy'
3. Drag the image which appears in the JS-Popup onto the desktop
4. See that a jpeg file has been created which contains the redirection page
Actual Results:  
wallpaper.jpeg is created with the HTML code in it which is returned by the server when trying to access a wallpaper without passing a referer.

Expected Results:  
Either save it as HTML page or save the image from cache.

HTTP-Header log when dragging the image to desktop:


http://anisearch.de/wallpaper.php?vid=21456

GET /wallpaper.php?vid=21456 HTTP/1.1
Host: anisearch.de
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6 (.NET CLR 3.5.30729)
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: de-de,de;q=0.8,en-us;q=0.5,en;q=0.3
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 30
Connection: keep-alive
Cookie: cookname=herojoker; cookid=165a716cb8ccd911f612e14bf48047ed; releases_titel=1; anime_titel=15; anime_prozent=9999; anime_status=585; anime_c=alle; ep_filter=2; ftyp1=1; forder1=2; ftyp2=2; forder2=2; review_titel=7; select_search_anime=2; missing=256; releases_show=1; anisearch_lang=german; chara_tags=inline; textbox_profil=20; sid=f62296a5cce989ac7f12de7afd00db21

HTTP/1.x 200 OK
Date: Fri, 13 Feb 2009 21:27:18 GMT
Server: Apache/2.2.3 (Debian) PHP/5.2.0-8+etch11
X-Powered-By: PHP/5.2.0-8+etch11
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Content-Encoding: gzip
Vary: Accept-Encoding
Content-Length: 382
Keep-Alive: timeout=15, max=100
Connection: Keep-Alive
Content-Type: text/html
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Updated

7 years ago
Version: unspecified → 3.6 Branch

Updated

7 years ago
Whiteboard: [CLOSEME 2010-11-01]

Comment 2

7 years ago
No matter how I try and save the image I get a corrupt JPG.

I tried to drag the picture from the popup to the desktop
I tried to do view picture and drag to the desktop
I tried to do view picture and save image as

This seems to be a TE issue...

Updated

7 years ago
Assignee: nobody → german
Component: General → German
Product: Firefox → Tech Evangelism
QA Contact: general → german
Version: 3.6 Branch → unspecified

Updated

7 years ago
Summary: Drag & Drop image to desktop saves as jpeg even if HTML is sent → anisearch.de - Drag & Drop image to desktop saves as jpeg even if HTML is sent
Works for me now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.