If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

using the moveTo() method or setting the top/left properties of an xul panel element to move the popup causes it to appear in random locations

RESOLVED DUPLICATE of bug 474149

Status

()

Core
XUL
--
major
RESOLVED DUPLICATE of bug 474149
9 years ago
9 years ago

People

(Reporter: sdb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.6) Gecko/2009020911 Ubuntu/8.10 (intrepid) Firefox/3.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.6) Gecko/2009020911 Ubuntu/8.10 (intrepid) Firefox/3.0.6

If you open an xul panel popup and then try to move it to a different location on the screen it causes the popup to appear in a location completely different from the one specified.  I've attached an extension for testing purposes.


Reproducible: Always

Steps to Reproduce:

1. Install the test extension.
2. Left click on the blue play button in the statusbar to open the panel.
3. Left click on the panel and hold the mouse button down.  Drag the mouse cursor to move the panel.  With a left click you are changing the top/left properties of the panel element.  You'll notice that it's almost like you're fighting the panel to get it to a new position.  It flickers and constantly moves to random locations.
4. Now right click on that panel and drag it.  With a right click you are calling the panel's moveTo() method.  The same behavior occurs no matter how you try to move the panel.
5. Click on your browser window to close the panel.
6. Right click on the blue play button in the statusbar to open a dialog window.
7. Hover over the large play button in the dialog window.
8. A panel will popup over the large play button.  Try left clicking and dragging and then right clicking and dragging.  You'll notice that the behavior of the panel is much more erratic when it's opened and moved from within the dialog window.

The strangest part of this bug is that when you right click and drag the panel from the dialog window it seems to completely ignore the x coordinate.  As a test, right click on the panel from the dialog window and drag it slightly.  You should see some text on your statusbar that lists the x coordinate for the event, the offset, and the panel.  The panel's left border should appear at the panelX coordinate listed in the statusbar.  I've also used the DOM Inspector to view the current x/y settings and the panel.boxObject.screenX/Y properties are always different from the panel.left/top properties when you use the moveTo() method on the dialog window's panel.
(Reporter)

Comment 1

9 years ago
Created attachment 362390 [details]
an extension for testing this bug

Updated

9 years ago
Component: Menus → XUL
Product: Firefox → Core
QA Contact: menus → xptoolkit.widgets

Comment 2

9 years ago
This should be fixed by the patch in bug 474149.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 474149
(Reporter)

Comment 3

9 years ago
I'm not sure if this only occurs on my operating system, but I just tested the latest trunk in Kubuntu 8.10 64-bit (kde 4.2) and it still exhibits the same behavior.  I can't tell any difference in the latest trunk with the test extension I attached above.

ftp://ftp.mozilla.org/pub/firefox/nightly/latest-trunk/firefox-3.2a1pre.en-US.linux-x86_64.tar.bz2
You need to log in before you can comment on or make changes to this bug.