If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Valid HTTP/1.0 request returns blank page

RESOLVED WORKSFORME

Status

Mozilla Messaging
Server Operations
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Derek Chen-Becker, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: 

I'm using a squid web proxy and when I go to the specified URL I get a blank page. I did a packet capture and squid sends a valid HTTP/1.0 request. The server replies with a 200 OK, but no content in the response. I'm attaching the packet capture. If I change firefox to not use the proxy, it makes an HTTP/1.1 connection which works fine.

Reproducible: Always

Steps to Reproduce:
1. Make an HTTP/1.0 request to the url.
2.
3.
Actual Results:  
Blank page

Expected Results:  
The real page

I'm attaching a packet capture
(Reporter)

Comment 1

9 years ago
Created attachment 362404 [details]
A packet capture of the squid request

Captured from wireshark (pcap format)
Is this still hapenning, I can't reproduce this using the same exact payload as in the capture.
(Reporter)

Comment 3

7 years ago
Looks like it's working fine now. In fact, the original URL (http://www.mozillamessaging.com/en-US/thunderbird/early_releases/downloads.php) appears to not exist anymore.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.