data corruption when moving/copying messages from Local Folders to IMAP folders

RESOLVED DUPLICATE of bug 477799

Status

Penelope
Mail Window
--
critical
RESOLVED DUPLICATE of bug 477799
9 years ago
9 years ago

People

(Reporter: Gary Hooper, Assigned: Matt Dudziak)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Build Identifier: 8.0.0b5

i have several messages distributed across many folders under Local Folders.  (these have been imported from Eudora 5; they look fine upon inspection, meaning that the import of these messages seems to have worked just fine.)

sometimes, when copying either small sets of individual messages or an entire folder of messages from Local Folders to my IMAP Inbox, the copy fails.  (also seen when moving messages.)  no error is displayed. however, the copied/moved message shows a header with current data (not actual date) and all other header info and msg body missing.  if i copy the same message again, it may work.  reducing the number of messages copied in a batch seems to reduce the probability of this occurring, but not eliminate it.  it seems to happen more frequently with larger messages, although it still happens with small messages too.

Reproducible: Sometimes
(Reporter)

Comment 1

9 years ago
note that if i copy/move the messages individually, they copy/move correctly.

Comment 2

9 years ago
copy to/from imap is not unread of. for example

 bug 477799 Body of message is missing when copying a message that contains the NUL character from local folder to imap folder 
 Bug 346687 -  Copying a folder from IMAP to local folders doesn't copy messages whose headers aren't downloaded
 bug 450212 Mail copy from local mail folder to IMAP folder fails due to excess space in flag data field of IMAP append command, if some tags are removed from a mail at local mail folder 
 bug 83396 dataloss, fixed1.8.0.2, fixed1.8.1, qawanted, verified1.7  	Alert "message contains bare newlines" displays and lost messages when copying msgs from Local(or other IMAP account)folder to an IMAP account folder
(Reporter)

Comment 3

9 years ago
Created attachment 388081 [details]
file contains a single message that does does transfer correctly from local to IMAP

when copying this message from Local Folders to IMAP, it is not transferred correctly.  in this case, body is missing.  if folder contains additional messages, when copying all, all messages copied after this one has been copied are corrupted (header and body).
(Assignee)

Comment 4

9 years ago
(In reply to comment #3)
> Created an attachment (id=388081) [details]
> file contains a single message that does does transfer correctly from local to
> IMAP
> 
> when copying this message from Local Folders to IMAP, it is not transferred
> correctly.  in this case, body is missing.  if folder contains additional
> messages, when copying all, all messages copied after this one has been copied
> are corrupted (header and body).


The email you attached also has a blank body (probably as a result of the same bug). The description, however, makes me think this is a duplicate of 477799 so I'l mark it as such.

Matt
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 477799
You need to log in before you can comment on or make changes to this bug.