Closed Bug 478584 Opened 11 years ago Closed 9 years ago

"Reply" in hotmail does not quote original email

Categories

(Core :: General, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 538892

People

(Reporter: theosib, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090212 Shiretoko/3.1b3pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090212 Shiretoko/3.1b3pre

I'm using the nightly build.  If I reply to an email in Firefox, the message I'm replying to does not appear in the exit box, and before I start typing, the cursor is the same height as the edit box.

If I login to hotmail using IE, reply causes the original email to be properly quoted.  This also works correctly in (the windows version of) Firefox 3.0.6.  So I think this problem is specific to the nightly builds of 3.1.


Reproducible: Always
hotmail does not work in ff3.1b2
It's known that 3.1b2 doesn't work with hotmail.  When I investigated that, I found an existing bug report on that.  Then I updated to the nightly builds.  The nightly build works way better, but there are still problems.
Have you tested this using a new profile, with absolutely no extensions or customizations?

This bug does not exist in 3.2 Trunk.  I haven't tested 3.1 Branch.
I took it a step further and tried it from a new user account, so all user-local stuff is completely clean, and I disabled all plugins.

The behavior is the same.

However, one thing I have noticed is that SOME emails will quote properly, while some will not.  With 3.0.6, all of them quote just fine.  Definitely a regression, and definitely not user- or plugin-specific.

Should I switch over to the 3.2 nightly builds?  I'm on 3.1 because I thought I'd see if I could beta-test for that while it's not out yet.
Try the following:

1. Go to about:config and change the value of general.useragent.extra.firefox from Shiretoko/3.1b3pre to Firefox/3.0
2. Log off and log back into Hotmail.
3. See if replies now work for those emails.

If that works, it's a Microsoft problem.

p.s. What are the characteristics of the emails for which reply is not working properly?  Does it work properly if you click reply on a bugzilla email?  Just asking because that would be the only type of email we would have in common and would allow other to test.
I changed the user agent as you suggested.

The problem of not quoting goes away, but now it screws up in an entirely new way, where the edit window takes up about 1/3 of the width that it should.  This behavior is consistent.

So, yes, Microsoft is doing something different depending on the user agent, but it's also true that Firefox is doing something different that makes it misbehave.
Did you actually try with a new profile (i.e. create a new, clean profile just to test), as I suggested?  You said, "I took it a step further", but that is not the same as saying you actually tried a new profile.
Product: Firefox → Core
QA Contact: general → general
Sorry.  I was unclear.  I was not satisfied to create just a new user profile.  I created a whole new user account.  I figured that would eliminate even more variables, no?
Does this only affect Firefox 3.1 beta 3 pre on Apple's OS X ? 
I don't know where to download Firefox 3.1b3pre so I cannot test it on Windows XP. 

I am this bug will affect windows and Linux users also.
I am Sure this bug will affect windows and Linux users also.
(In reply to comment #5)
> Try the following:
> 
> 1. Go to about:config and change the value of general.useragent.extra.firefox
> from Shiretoko/3.1b3pre to Firefox/3.0
> 2. Log off and log back into Hotmail.
> 3. See if replies now work for those emails.
> 
> If that works, it's a Microsoft problem.
[...]

...however, in that case it can be filed on this Bugzilla but in the "Tech Evangelism" product, not the "Firefox" product, and as a bug which "blocks" bug 334967. (See also http://www.mozilla.org/projects/tech-evangelism/site/procedures.html about what to do before and after reporting an Evangelism bug.)
I tried changing the useragent, and it doesn't help.  I get two results.  Either the contents of the email I'm replying to aren't quoted, or the quoting is fine, but the edit box is really really narrow.
testing on:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090524 Firefox/3.0  (NOTE: I changed my agent to Firefox/3.0 as per comment #5)

I saw the original problem and changing my user agent resolved the problem.  The UI has some split pane thing which doesn't look right, but at least I can reply and forward email messages again.
Confirmed on FF 3.5 nightly 20090617r25988.  Same narrow editor with FF3.0 User Agent.
Duplicate of bug 538892?
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 538892
You need to log in before you can comment on or make changes to this bug.