Swipe left and right gestures produce incorrect action

VERIFIED INVALID

Status

()

Firefox
Keyboard Navigation
VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: Thom, Unassigned)

Tracking

3.5 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2

When I swipe left or right, Firefox moves through the tabs (either left or right) instead of going forward and back in history.  All the other gestures work as stated.

Reproducible: Always

Steps to Reproduce:
1. Open a few tabs
2. Go through a few links in one tab

Actual Results:  
3. Try to go back or forward in the middle of the tab history and it just goes through the open tabs

Expected Results:  
Go back and forth between history of the open tab.
Thom, I think something messed-up with your preferences. Can you please open about:config and search for gestures? What values are set for swipe.left and swipe.right?
(Reporter)

Comment 2

9 years ago
I checked the settings:

swipe:left    Browser:BackOrBackDuplicate
swipe:right   Browser:ForwardOrForwardDuplicate

I don't think there's a hardware issue since it works fine (with same settings) in Minefield.
Are you using the same profile for Shiretoko and Minefield? Or do you start the latter one with its own profile? Just to make sure that nothing in the profile has been messed-up.
Version: unspecified → 3.1 Branch
(Reporter)

Comment 4

9 years ago
Same profile for both.  I installed Minefield after I noticed the issue with Shiretoko.  I can go back to Shiretoko an still repeat the gesture bug and go back to Minefield with no gesture bug.
Interesting. Do you see any errors listed in the Error Console? Can you further please try to use Shiretoko with a fresh profile? Would be interesting if the issue still remains.
(Reporter)

Comment 6

9 years ago
When I ran the program from the terminal, I notice that MultiCluth was running in the background, which I had forgotten about since I don't really use it.  I removed the pref. panel from system preferences, but it still did not solve the problem, so I had to reinstall MultiClutch and then remove a swipe profile I had for Firefox and then remove the preference panel. MultiClutch is sketchy!  Now the problem is solved.  Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Nice to hear that its no fault on our side. Thanks Thom for checking this out. As said I'll change this bug to invalid.
Status: RESOLVED → VERIFIED
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.