print preview only shows main content on first page (of 3?)

RESOLVED DUPLICATE of bug 129941

Status

()

Core
Printing: Output
RESOLVED DUPLICATE of bug 129941
9 years ago
9 years ago

People

(Reporter: shaver, Unassigned)

Tracking

1.9.1 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

When I print-preview this page, I only see the main body text on the first page of 3; the remaining two pages just have sidebar and ad-footer on them.  I see this on both Vista and OS X.

Don't see a print-related stylesheet in the page.

(I'm skeptical that it's really only 3 pages, too, since the portion of the main body it shows is quite a bit less than a third on my screen.)
From the URL's source:

> #main-wrapper {
> [snip]
> overflow: hidden;      /* fix for long non-text content breaking IE sidebar float */

overflow:hidden makes us gladly hide all the content that overflows the first page. (I confirmed that this was the root cause by manually adding style="overflow: visible" to the "main-wrapper" node, in DOM inspector. That change fixes the problem.)

This is bug 129941.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 129941
You need to log in before you can comment on or make changes to this bug.