Navigation in files with arrow keys needs to be enhanced

RESOLVED DUPLICATE of bug 478651

Status

Skywriter
Editor
P1
major
RESOLVED DUPLICATE of bug 478651
10 years ago
9 years ago

People

(Reporter: whimboo, Assigned: Dion Almaer)

Tracking

Details

(Reporter)

Description

10 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090215 Shiretoko/3.1b3pre Ubiquity/0.1.5 ID:20090215020429

The navigation inside the editor while editing files needs to be enhanced drastically. Right now it's hard to navigate at all with the arrow keys. Only a keypress event is handled while holding down the keys results in no action. Scrolling through a large file isn't possible that way.

I was only able to test this on OS X.
related to bug #475374 ?
(Reporter)

Comment 2

10 years ago
Somehow yes, but on OS X it already fails by holding down the arrow key only. Whether which one you are using.

Comment 3

10 years ago
sounds like it is related to this bug https://bugzilla.mozilla.org/show_bug.cgi?id=478651 I run linux usually, and had the same problem.
This is a mass migration from Mozilla Labs :: Bespin to Bespin :: General.

This bug likely still needs to be triaged and categorized.
Component: Bespin → General
Product: Mozilla Labs → Bespin
QA Contact: bespin → general
Target Milestone: -- → ---
Version: 0.1 → 0.1.1

Comment 5

9 years ago
Is this bug still there? I guess when holding down the arrow keys the editor is moving quite well => mark bug as fixed?
Yeah, this looks like it was fixed in changeset 1c2e1d714cb6; however, it also appears that this is a duplicate of bug 478651, so marking it as such.

Also marking it as dependent on bug 475374, as well as moving it to the Editor component.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Component: General → Editor
Depends on: 475374
OS: Mac OS X → All
QA Contact: general → editor
Hardware: x86 → All
Resolution: --- → DUPLICATE
Target Milestone: --- → 0.1.3
Duplicate of bug: 478651
Assignee: nobody → dion
Priority: -- → P1
You need to log in before you can comment on or make changes to this bug.