[RTL] Sometimes toolbar buttons in Add-ons Manager, Page Info window and Error Console are distorted

RESOLVED DUPLICATE of bug 477732

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 477732
9 years ago
9 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

({rtl})

3.5 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 362544 [details]
Distorted toobar buttons

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; fa; rv:1.9.2a1pre) Gecko/20090215 Minefield/3.2a1pre

For now I don't have exact steps how to reproduce this bug. But sometimes the toolbar buttons in the mentioned windows are distorted. See the attached screenshot. After a restart all of these buttons are drawn correctly. So it's probably an issue when switching into RTL mode?

Comment 1

9 years ago
Do you see this when using Force RTL or an RTL langpack?
When the distortion happens in one of those windows, does it happen in all the rest?
When this happens, can you please use DOM Inspector to see what style rules are applied to the tab elements?  The interesting elements should be anonymous <xul:spacer> nodes inside a <xul:tab> element with class "tabs-left" and "tabs-right".

Comment 2

9 years ago
See also bug 477732 (the underlying reason for this bug is probably the same as bug 477732; for some reason RTL is more sensitive ?). Probably a dupe.
(Reporter)

Comment 3

9 years ago
Thanks philippe! That's exactly the same issue. Marking as dupe.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 477732
Maybe the fonts of the RTL language you tested have a higher line height? Then we're hitting the unstable case that Zack mentioned in bug 477732 comment 4, and the CSS fix in that bug is the right way to fix this bug.

Comment 5

9 years ago
(In reply to comment #4)
> Maybe the fonts of the RTL language you tested have a higher line height? Then
> we're hitting the unstable case that Zack mentioned in bug 477732 comment 4,
> and the CSS fix in that bug is the right way to fix this bug.

The fix should be applied to the core product, right?  (Just checking to see if I need to add the CSS fix to the fa locale's intl.css or not)
(In reply to comment #5)
> The fix should be applied to the core product, right?

Yes.
You need to log in before you can comment on or make changes to this bug.