Closing Firefox while being in a Print Preview deletes all savedtabs

RESOLVED DUPLICATE of bug 354894

Status

()

Firefox
Tabbed Browser
--
major
RESOLVED DUPLICATE of bug 354894
9 years ago
9 years ago

People

(Reporter: ShadowmanX, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6

If you go in the print preview for a web page and then close firefox, then any tabs you had open before are lost --> When opening firefox again only the start page is there and no more tabs which had been open before.
There was no other window of firefox open and there was no prompt that asked if I wanted to save the tabs.

Reproducible: Always

Steps to Reproduce:
1. open firefox and open some tabs and webpages in there
2. close firefox and save the tabs
3. open firefox again and choose anyone of the tabs
4. open the print preview
5. close firefox (note: don't click the Close button in the window, click the X Button on the upper right. The Close Button works)
Actual Results:  
After opening firefox again, all tabs are gone and only the start page shows

Expected Results:  
all tabs I had open should be open again after reopening firefox
I tried this on a non-64bit Vista installation. When I click the X button, it closes the print preview window, and then the browser window shows with the three tabs. I'll try on the 64-bit machine, next.

Comment 2

9 years ago
It will only save tabs on close of the last window. If you have another window open (i.e. print preview) it won't save the session because Firefox hasn't exited yet.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 354894
You need to log in before you can comment on or make changes to this bug.