Moving Back, Home, Address to Menu tool bar causes DebugNextPageMI is NULL Javascript error on new windows

VERIFIED INVALID

Status

()

VERIFIED INVALID
10 years ago
10 years ago

People

(Reporter: Chowarmaan, Unassigned)

Tracking

3.0 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6 FirePHP/0.2.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6 FirePHP/0.2.4

When you modify the main menu bar to move the Back button, Home button, address bar and search bar to the menu and close the Address toolbar, and then Javascript opens a new window, the error occurs.
Resetting the menus will correct this. 

Reproducible: Sometimes

Steps to Reproduce:
1. View/Toolbars/Customize
2. Move Back, Home, Reload, Address Bar and search bar to main menu
3. Restart browser, use something like PHPMyAdmin to prompt with a date box to select a date for MySQL field.
4. Javascript error: DebugNextPageMI is null is displayed.
Actual Results:  
Error box occurs with error: DebugNextPageMI is Null.  Closing box allows window to continue to open.

Expected Results:  
New window should open without error.
Reporter, this does look more like an extension problem. Please start Firefox in Safe Mode and check if that happens without any active extension. I suspect that the error will be visible because I cannot find such an identifier in the code base of Firefox.
Component: Menus → Toolbars
QA Contact: menus → toolbars
Version: unspecified → 3.0 Branch
(Reporter)

Comment 2

10 years ago
Restarting with all plugins disabled solved the problem.  Resetting the menus works as well.  I will attempt to reactivate each plugin 1 by 1 to try to determine the plugin that has the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Thanks Steven. You can get in contact with the add-on developers to get this thing fixed. For Firefox we only set fixed when a patch was checked into our code base. Thanks for your help.
Status: RESOLVED → VERIFIED
Resolution: FIXED → INVALID
(Reporter)

Comment 4

10 years ago
It was caused by the Zend Studio Toolbar Firefox plugin.  I have reproduced the error with just this plugin running and have since removed it from my system.  I have also reported this as an error to Zend.
That's great. Thanks again.
You need to log in before you can comment on or make changes to this bug.