If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can't click a link in a unordered list using CSS

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: enrodri86, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; ca; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; ca; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6 (.NET CLR 3.5.30729)

I am developing a CSS for my personal web page, and I can't click on the links of the menu. It woorks fine in IE, but it does not work in ff3.

I am attaching the XHTML and CSS files.

Reproducible: Always

Steps to Reproduce:
1.Open the .htm file I am sending to reproduce the bug with FF3.
2.Try to click on the links I marked with a red dotted border.
Actual Results:  
Can't click on the links. The links behave as normal text.

Expected Results:  
Follow the link and open the other page.
(Reporter)

Comment 1

9 years ago
Created attachment 362864 [details]
The CSS file
(Reporter)

Comment 2

9 years ago
Created attachment 362865 [details]
XHTML file
The links are covered by the h1 and the h2 because those are relatively positioned. You can set a width on them so that they don't extend all the way to the right.

Next time you find that something is not clickable, Firebug can help you find out what covers it: Just right-click on the unclickable part and choose "Inspect Element" - Firebug will show you the element that is really under the mouse.
(Reporter)

Comment 4

9 years ago
Thanks! Should we close the bug as it seems it was my problem, or keep it open, because in IE7 it worked while in FF3 not? Or is it a problem of IE7, because FF3 behaviour was ok?
I'm not 100% sure, but I think it's a problem in IE7. Let's close this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.