Copy/paste error when creating a list of emails

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: hackersword, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-07-14)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6 (.NET CLR 3.5.30729)
Build Identifier: version 2.0.0.19 (20081209)

When trying to copy/paste a long list of emails into a mailing list card, the second email in the list is always lost.

Reproducible: Always

Steps to Reproduce:
1. Open text file, type in 3-6 emails, each email on new line
2. Select all, Copy
3. Open up list from address book
4. Paste emails into field.  Shows up as comma seperated list on one line.
5. Hit OK
6. Reopen List, see whatever email was on second line of text file, did not get imported
Actual Results:  
one email is missing in the list in the address book, compared to the source file where you copied the emails from.


This is very embarrassing bug.  As IT admin, I recommended everyone in office move to Thunderbird.  Been in place for several months and users have been generating email lists like this (usually 20-100 email addresses in a list).  Only recently was this noted, so previously generated mail did not get sent to all intended recipients.
(Reporter)

Comment 1

10 years ago
I would delete the last paragraph if I could, per Bugzilla etiquette, but I can't seem to.  Apologize for venting frustration, just meant to highlight the severity of retroactively notify all users to go through all old messages and notify anyone if a message was not sent out.
Seems to work fine on trunk. Can you try
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-trunk/
Version: unspecified → 2.0
This took me a bit to figure out the bug. I haven't tried it on trunk, but there's a missing step above. 

Step number 4.5 should be, "Enter an email address on the next line below the one where you pasted."

When that is done, trouble ensues. Otherwise, it seems to work fine for me.

Comment 4

9 years ago
Michael, hackersword, can you try ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-1.9.1/ and report your results?  backup your profile first
Severity: critical → normal
Whiteboard: closeme 2009-07-14
Just tested. Seems fixed to me.
Let's call it WFM then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.