Last Comment Bug 479069 - Timepicker does not display AM/PM on Ubuntu, Datepicker displays an arbitrary "October"
: Timepicker does not display AM/PM on Ubuntu, Datepicker displays an arbitrary...
Status: RESOLVED INCOMPLETE
[CLOSEME 2010-12-01]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Linux
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://jrharshath.wordpress.com/2009/...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 09:51 PST by jrharshath
Modified: 2010-12-02 12:58 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Thunderbird Addressbook "New Contact" dialog showing weird " .okt. " birthday. (23.62 KB, image/png)
2010-06-18 04:20 PDT, Per Olav Kroka
no flags Details

Description User image jrharshath 2009-02-18 09:51:10 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.6) Gecko/2009020911 Ubuntu/8.10 (intrepid) Firefox/3.0.6 FirePHP/0.2.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.6) Gecko/2009020911 Ubuntu/8.10 (intrepid) Firefox/3.0.6 FirePHP/0.2.1

My friend built an extension for firefox, and I noticed that the timepicker control (in xul) does not display the AM/PM select, neither does it provide a 24 hour clock. (only on Ubuntu).

screenshot: http://jrharshath.wordpress.com/files/2009/02/screenshot-datepicker.png

I live in India, and so it just shows IST instead of AM/PM (see screenshot)

This problem occurs only on Ubuntu (I have not tried other distros). The same firefox extension was displaying AM/PM correctly in Firefox when running on Windows Vista.

The same problem occurred with the datepicker control: it was displaying an arbitrary "October" between the Day number and Month number. (This too, only on ubuntu).

I wonder why this is hapenning.

Reproducible: Always

Steps to Reproduce:
1. Open firefox in ubuntu
2. Open a firefox extension that has the datepicker/timepicker controls (the one I used is not yet published. I am not its author).
3. See how the timepicker/datepicker look.
Actual Results:  
We see that the timepicker has no AM/PM selection
Also, the datepicker displays a random "October" in it, irreespective of the month selected in the datepicker.

Expected Results:  
Expected results are seen on Windows Vista (on the same version of firefox): neither the datepicker nor the timepicker have anything unuasual. AM/PM is present, and the extraneous "October" is not.
Comment 1 User image Per Olav Kroka 2010-06-18 04:16:44 PDT
The Thunderbird Adressbook shows the same symptom regarding "October" only using the localised short form in the "edit birthday field".

Thunderbird Version info:
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.9) Gecko/20100423 Lightning/1.0b1 Thunderbird/3.0.4

Just for reference, but I don't think it matters for other than exclusion:
Local language is Norwegian Nynorsk (no_nn).

Appended image (OctoberDateBug.png) shows the "New Contact" dialog, "Private" tab.  Note the "Fødselsdag" (Birthday) field shows " . okt. ".  The "okt" part I expect beeing the short form of "oktober" which is "October" in norwegian.

Inserting a date in the field -- say 1st April would change the field to "01. okt. 04".  
It is possible to edit both "01" and "04", but ". okt." seems to be static and impossible to remove.  


I expect this confirms the bug report of "jrharshath".

PS: Luckily, when displaying a contact (ie. not in edit-mode), the ". okt." part does not show.
Comment 2 User image Per Olav Kroka 2010-06-18 04:20:16 PDT
Created attachment 452240 [details]
Thunderbird Addressbook "New Contact" dialog showing weird " .okt. " birthday.
Comment 3 User image Tyler Downer [:Tyler] 2010-11-13 13:04:58 PST
Reporter, please retest with Firefox 3.6.12 or later in a fresh profile (http://support.mozilla.com/kb/Managing+profiles). Also update your plugins (flash, adobe reader, java, quicktime, silverlight, etc.) Go to the developer's website and download the latest version from there. If you no longer see this issue, please close this bug as RESOLVED, WORKSFORME. If you do see the bug, please post a comment.
Comment 4 User image Per Olav Kroka 2010-11-15 03:31:31 PST
I have Firefox 3.6.12 and Mozilla Thunderbird 3.1.6, but I cannot see that any Firefox version should affect this. (Mozilla Thunderbird is standalone right?  How should it even be possible to test Mozilla Thunderbird New Contact dialog using Firefox?)

Anyhow, I still see the weird " .okt. " in the birthday field of the "New Contact" field.
Comment 5 User image Tyler Downer [:Tyler] 2010-12-02 12:58:05 PST
No reply, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.

Note You need to log in before you can comment on or make changes to this bug.