when comment contains a reference to another bug, add comment to that bug and notify people

RESOLVED WONTFIX

Status

()

Bugzilla
Creating/Changing Bugs
--
enhancement
RESOLVED WONTFIX
9 years ago
9 years ago

People

(Reporter: Peter Pawlowski, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.0.6) Gecko/2009011912 Firefox/3.0.6
Build Identifier: 

Suggestion: When a comment is entered on a bug report that contains text that "references" another bug report (i.e. will be displayed as a link to that bug report, like the text "bug 1234"), add a comment to the other bug report that indicates that it has been mentioned elsewhere and send an email to the people on that bug report.

I have implemented this and will submit a patch.

What I implemented:

When a new comment is submitted, use the regex for displaying bug links in a comment to determine if another bug was referenced.

For each unique other bug referenced, create a new comment on that bug indicating the reference. The new comment is of a new type (similar to the types for "duplicate of", etc.) and contains the number of the bug report referenced, as well as the comment number.

Also, send an email to the reporter, assignee and CCs notifying them that the "referenced by" comment has been added.

One thing my patch does not contain is the ability to turn this off, which would need a new parameter.

Reproducible: Always

Comment 1

9 years ago
This is a good way to spam a lot of people from a single place. If it worths referencing another bug, you should use dependency fields, or wait for bug 12286 to be implemented (assuming we implement it).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

9 years ago
Yeah, it would be similar to bug 12286 (thought that bug is currently resolved wontfix).

I can see it being a potential way to spam a lot of people, especially in a very large and diverse userbase like Mozilla. For our internal Bugzilla, which is fewer than 100 users, it has worked nicely.

Thanks for considering it...

Comment 3

9 years ago
Peter, just FYI: bug 12286 is wontfix due to the custom field introduced by bug 287334 . So, in bugzilla 3.4 you'll have a custom field for bugs.

But, this custom field doesn't work bi-directional (yet), this will be introduced by bug 251556.  Don't know if that will be ready for 3.4 .

Comment 4

9 years ago
It seems like this would be a good enhancement (or usage?) of the bug id custom fields.  This actually includes more data: It includes the comment that it was mentioned in.

Possibly you wouldn't want to allow multiple references per bug; one could use the bug id custom field to track that.

(In reply to comment #1)
> This is a good way to spam a lot of people from a single place.

I don't think that's a real reason not to implement this.  For private installations (ie in a business or with a limited number of users) I think this is fine.  I wouldn't ever turn this on for a site like bugzilla.mozilla.org though.

Ciao!
(Reporter)

Comment 5

9 years ago
My company has been using this feature in-house for the past several months and we do find it useful.

Keep in mind that not all Bugzilla deployments are public-facing with thousands of users and open registration.

Our user base is small and trusted because they are all employees here, and our deployment is behind a firewall, which makes it a much different scenario than, for example, the Mozilla Bugzilla.

(In reply to comment #1)
> This is a good way to spam a lot of people from a single place.

I was intending that the feature be disabled by default, and only enabled when an administrator explicitly enables it.

(In reply to comment #1)
> If it worths
> referencing another bug, you should use dependency fields, or wait for bug
> 12286 to be implemented (assuming we implement it).

Filling out a field kind of defeats the purpose, since it requires explicit action. The whole point here is to detect references automatically to catch potentially interesting and unintended relations.
You need to log in before you can comment on or make changes to this bug.