Closed Bug 479120 Opened 13 years ago Closed 5 years ago

jsapi.h is affected by DEBUG, which is not included in js-config --cflags output

Categories

(Firefox Build System :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 939505

People

(Reporter: jimb, Unassigned)

Details

There are a number of declarations in jsapi.h that are affected by whether or not DEBUG is #defined.  js-config --cflags is supposed to include all #definitions that affect the SpiderMonkey API.

Also, DEBUG is not namespace-clean: spidermonkey clients might very well have DEBUG macros of their own.

So, DEBUG should be renamed JS_DEBUG, and captured in js-config.
jimb: could you please triage this old bug of yours?
Flags: needinfo?(jimb)
Fixed in bug 939505.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(jimb)
Resolution: --- → DUPLICATE
Duplicate of bug: 939505
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.