bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Images are displayed as text files when clicking in hyperlinks of view page source window

RESOLVED DUPLICATE of bug 464339

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 464339
10 years ago
10 years ago

People

(Reporter: Rafael C. R., Unassigned)

Tracking

3.5 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2

(Sorry for the bad english, I'm brazilian)
When you are in the view page source window there are several links to files which are used in the page. But when you click in a link to an image file, you'll receive text-code with binaries instead the properly image (like images generated with php that doesn't have a defined mime-type).

Reproducible: Always

Steps to Reproduce:
1.Chose a web page that contains images.
2.Click with the right button , view page source
3.Click in a link that takes you to a image file
Actual Results:  
The view source page window doesn't show an image, it just returns a text-code with the image binaries

Expected Results:  
View Source Page must show the image as Firefox shows in a simple page
I can't reproduce the problem on latest trunk and branch builds on Windows.XP.
Can you give a link to an URL with this problem?
Also, are you on Windows Vista?
Version: unspecified → 3.1 Branch
Sorry, not too smart early in the morning, but I can't reproduce your problem on Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1b3pre) Gecko/20090218 Shiretoko/3.1b3pre either.
OS: Other → Windows 7
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 464339
(Reporter)

Comment 4

10 years ago
This bug happens in Windows 7 (at least)
You need to log in before you can comment on or make changes to this bug.