Thunderbird unable to handle malformed/corrupted Content-Type: multipart/related; as user wants (malformed : start= points non-existent content id, type= points non-existent content-type)

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
10 years ago
2 years ago

People

(Reporter: gsommer, Unassigned)

Tracking

(Blocks: 1 bug)

1.8 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121717 Mandriva/1.9.0.5-0.1mdv2009.0 (2009.0) Firefox/3.0.5
Build Identifier: 2.0.0.19 (20090114)

I got an e-mail from a SE telephone.
I'm able to open the e-mail, and look at the attachment - but I'm NOT able to forward/reply the email.
When trying to forward/reply Thunderbird does not attach the attachments in the e-mail.
I tried saving the e-mail as .eml file and changing "Content-Type: multipart/related;" to "Content-Type: multipart/mixed;".
This seems to work better for some reason?

I've uploaded the e-mail as .eml file at: http://freeshells.ch/~glemsom/Billede006.eml
(Though, I've modified the e-mail addresses)

Reproducible: Always

Steps to Reproduce:
1. Open http://freeshells.ch/~glemsom/Billede006.eml in Thunderbird
2. Try to forward the e-mail
Actual Results:  
The actual result with this e-mail is that it CAN be opened (though missing some text) - but the attachments are working.
The e-mail cannot be forwarded... Doing so will make Thunderbird loose the attachments.

Expected Results:  
I would expect Thunderbird to show the body text - and to be able to forward/reply the e-mail... Including attachments.
Can you attach the file to the bug please ?
Component: General → MIME
Product: Thunderbird → MailNews Core
QA Contact: general → mime
Version: unspecified → 1.8 Branch
(Reporter)

Comment 2

10 years ago
Created attachment 363083 [details]
Original e-mail (With e-mail addresses modified)

Email that Thunderbird cannot handle properly (though with e-mail addresses modified)
Where is "mail body" in the mail?

(Problem-1) Malformed mail.
> Content-Type: multipart/related; 
>  boundary="----=_Part_306225_27181879.1234966513326"; type="application/smil";
>  start="<AAAA>"
(A) Content-Type: header has start parameter, but there is no part with "Content-ID: <AAAA>".
(B) Content-Type: heder has type parameter, but there is no part with "Content-Type: application/smil".

See RFC 2387.
> http://www.faqs.org/rfcs/rfc2387.html
> 3.1.  The Type Parameter
>    The type parameter must be specified and its value is the MIME media
>    type of the "root" body part.  It permits a MIME user agent to
>    determine the content-type without reference to the enclosed body
>    part.  If the value of the type parameter and the root body part's
>    content-type differ then the User Agent's behavior is undefined.
> 3.2.  The Start Parameter
>    The start parameter, if given, is the content-ID of the compound
>    object's "root".  If not present the "root" is the first body part in
>    the Multipart/Related entity.  The "root" is the element the
>    applications processes first.
Sorry but I don't know proper behavior for malformed mail.

If "Display Attachments Inline" is enabled, both image/jpeg part and text/plain part(Tb probably considers "attachment") is displayed in message pane.

(Problem-2 : Bug 471402)
Even if correct parameters are specified, Tb fails to display mail body part when start is specified in "Conten-Type: multipart/related".

Comment 4

10 years ago
This message looks invalid either way. The first MIME part is image/jpeg with a name "Billede006.jpg" which could be referred to. The second part is text/plain which has a Content-ID that could be used as argument for "start", and in turn this could use "Billede006.jpg" as shown in bug 471402, but as it is plain text here, how would it be able to refer to the image part?
Summary: Thunderbird unable to handle Content-Type: multipart/related; → Thunderbird unable to handle malformed/corrupted Content-Type: multipart/related; as user wants
Duplicate of this bug: 549883
Summary: Thunderbird unable to handle malformed/corrupted Content-Type: multipart/related; as user wants → Thunderbird unable to handle malformed/corrupted Content-Type: multipart/related; as user wants (malformed : start= points non-existent content id, type= points non-existent content-type)
Glenn this might have been fixed by bug 351224. Could you take a few minutes and download the latest nightly ( http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central/ ), backup your profile and test and let us know if this is fixed or not ?
(Reporter)

Comment 7

8 years ago
I tried thunderbird-3.3a1pre.en-US.linux-x86_64.tar.bz2.

With this version, I can't even see the content of the email.
And reply/forward is still broken too.
Removing myslef on all the bugs I'm cced on. Please NI me if you need something on MailNews Core bugs from me.

Comment 9

2 years ago
The message is invalid as stated in comment #4. This is not a multipart/related message, it should be multipart/mixed.

This bug is seven years old. We have no resources to fix problems where invalid data is presented.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.