If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Add-on not found" error for sandbox versions of "QuickFolders" extension

VERIFIED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: fligtar, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
https://addons.mozilla.org/en-US/firefox/addons/versions/3254

If you try to download the last 2 sandbox versions of this add-on (while logged in), you'll instead download an html file with the "Add-on not found!" error. However, the files definitely exist because they can be downloaded without issue from the Developer Tools area at https://addons.mozilla.org/en-US/developers/versions/edit/63037
Created attachment 363149 [details]
Latest version of the extension
While I can reproduce the problem, I cannot confirm:

(In reply to comment #0)
> However, the files definitely exist because they can be downloaded without
> issue from the Developer Tools area at
> https://addons.mozilla.org/en-US/developers/versions/edit/63037

I get the same "addon not found" error on the developer pages.

Will now check how other add-ons behave.
I have uploaded these files and tried to remedy the situation by uploading a new file, but same problem. It actually pretends to d/l the (55kb) XPI file but that contains a web page instead (20kB). I tried to bump up the version number but it did not help. Have used same setup before (Fx3.0.6) so I suspect there was a change in the page processing. I get the same erratic behavior on

https://addons.mozilla.org/en-US/developers/versions/edit/63037

The file seems to be uploaded okay as it is displaying the correct size, just downloading is broken.
I just checked another two public, updated add-ons that are currently waiting for review (4457 and 517) and they work as expected.

It seems like the problem exists with the add-on in question only.
Summary: Sandbox versions can't be downloaded from "All Versions" page → "Add-on not found" error for sandbox versions of "QuickFolders" extension
I deleted Versions 0.9.9.3 and 0.9.9.4 then added 0.9.9.5 taking care not to step backwards on the page Version ... created! I clicked on Add release notes and stepped further to the page "Your changes have been saved". tried downloading the file
https://addons.mozilla.org/en-US/firefox/downloads/file/47388/quickfolders-0.9.9.5-tb.xpi
and get the same error again. Looks like I can not release any new version anymore. Is is possible the situation can be resolved by an AMO editor reviewing the extension and releasing it from the sandbox?

The problem might have been caused with 0.9.9.3  where I clicked back to access the link "becoming an editor" during the Release notes step. Whatever it is the db entries for this extensions need some tidying. Who to go to with this?
Actually, your new version works like a charm for me: I can download it properly on both the "all versions" as well as developer pages. Whatever was wrong with the previous versions, it seems to work now.

Sorry for the inconvenience!
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Looks like its resolved probably some cached info somewhere on a server :o) thanks 4 the help
Verified FIXED; fine for me too -- I downloaded using both IE 6 and Firefox 3.0.6, and installed into Thunderbird 2.0.0.19 just fine.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.