bump maxVersion numbers of the in-tree extensions to tb3.1a1pre/sm2.0b1

RESOLVED FIXED in Thunderbird 3.0b3

Status

RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: clarkbw, Assigned: mkmelin+mozilla)

Tracking

Trunk
Thunderbird 3.0b3

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

10 years ago
should be an easy fix

* inspector, see bug 467761 comment 1 for the blanket rs=sdwilsh
* irc?
* venkman?

magnus, phil, can one of you guys grab this?

Comment 1

10 years ago
See also bug 479130 - we probably should do the changes in the extension sources for SeaMonkey and Thunderbird at the same time.
What is 3.0b2 and 3.0b3pre for Thunderbird is 2.0a3 and 2.0b1pre for SeaMonkey, by the way.
(Assignee)

Comment 3

10 years ago
Created attachment 363284 [details] [diff] [review]
proposed fix

Oh, 3.1a1pre just for .mozilla-trunk perhaps?
(In reply to comment #3)
> Created an attachment (id=363284) [details]
> proposed fix
> 
> Oh, 3.1a1pre just for .mozilla-trunk perhaps?

Yes we want 3.1a1pre, however there are no differences between trunk and branch DOMI (it resides in its own repository: http://hg.mozilla.org/dom-inspector/).

Don't forget (as per comment 0) we have a blanket rs=sdwilsh.

Comment 5

10 years ago
and please, no "pre" in the SeaMonkey version, we want just "2.0b1" (else we'll probably go and ship a DOMI with 2.0b1 that's not compatible with it).
(Assignee)

Comment 6

10 years ago
Created attachment 363293 [details] [diff] [review]
proposed fix, v2

Ah.
Attachment #363284 - Attachment is obsolete: true
(Assignee)

Updated

10 years ago
Attachment #363293 - Attachment is obsolete: true
(Assignee)

Comment 7

10 years ago
Created attachment 363294 [details] [diff] [review]
proposed fix, v3

maxVersion 3.1a1pre for tb, 2.0b1 for sm.
(Assignee)

Comment 8

10 years ago
There's not a tinderbox for http://hg.mozilla.org/dom-inspector/ I assume? So it's ok to just push?
(In reply to comment #8)
> There's not a tinderbox for http://hg.mozilla.org/dom-inspector/ I assume? So
> it's ok to just push?

yes, although the tree is closed at the moment, but I doubt that will break it ;-)

Comment 10

10 years ago
Pushing should be OK, and the patch now looks good from a SeaMonkey POV, thanks for doing that!
Component: General → Build Config
QA Contact: general → build-config
(Assignee)

Comment 11

10 years ago
changeset:   697:f203dd8fa95f
http://hg.mozilla.org/dom-inspector/rev/f203dd8fa95f

->FIXED
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Summary: bump version numbers of the in-tree extensions to b2, b3pre → bump maxVersion numbers of the in-tree extensions to tb3.1a1pre/sm2.0b1
Target Milestone: --- → Thunderbird 3.0b3
(Assignee)

Updated

10 years ago
Duplicate of this bug: 479130
You need to log in before you can comment on or make changes to this bug.