Different text/font when I print to Adobe PDF Writer

RESOLVED DUPLICATE of bug 422253

Status

()

RESOLVED DUPLICATE of bug 422253
10 years ago
9 years ago

People

(Reporter: ray-temp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; MSDigitalLocker; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6

Whenever I print to the PDF writer, the text and font is different that was displayed on the screen.  Photos/graphics are fine.  However, this does not happen with IE.

Reproducible: Always

Steps to Reproduce:
1.  Basically the same as stated above
2.
3.
Actual Results:  
7KH6HUYLFH&DSDELOLW\  3HUIRUPDQFH6&36WDQGDUGVSURYLGHDIUDPHZRUNIRU
LPSURYHPHQWDQGKHOSWRHQKDQFHWKHFDSDELOLWLHVDQGSHUIRUPDQFHRIVHUYLFH
RSHUDWLRQVZKLOHJXLGLQJWKHLUR QJRLQJGHYHORSPHQ7WKH6&33URIHVVLRQD6OHUYLFH
6WDQGDUGGHILQHVPDMRUFULWHULDUHTXLUHGWRRSHUDWHDVXFFHVVIXOSURIHVVLRQDOVHUY LFH
RSHUDWLRQ7KHVHFULWHULDDUHEURNHQGRZQLQWRGHWDLOHGEXVLQHVVHOHPHQWVHDFKZLWK

Expected Results:  
This was supposed to have been a paragraph, in english, with typical, normal font/text.

Printed to a PDF file -- the same as Internet Explorer does.

Comment 1

10 years ago
Printing with CutePDF as the print driver exhibits similar behavior (Windows XP
SP3). 

Under FF 2.0.0.20, printing an html document containing Courier, Helvetica and Helvetica-Bold fonts generates a PDF where CutePDF substitutes CourierStd, ArialMT and Arial-BoldMT. When printing the very same html document from Firefox 3.5, CutePDF substitutes two True Type custom fonts (TTE109B009t00, TTE1997920t00).

I also found FF 3.5 printing to CutePDF now converts the Courier font to a graphic image of the original text. Firefox 2.0.0.20 does not exhibit this behavior. The result is that CutePDF generates a significantly larger PDF when used with Firefox 3.5.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 422253
You need to log in before you can comment on or make changes to this bug.