Task list and task view are empty [JavaScript Error: "setting a property that has only a getter" in calendar-task-tree.xml]

VERIFIED FIXED in 1.0b1

Status

defect
--
major
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: ssitter, Assigned: ssitter)

Tracking

({regression})

Dependency tree / graph
Bug Flags:
blocking-calendar1.0 +

Details

()

Attachments

(1 attachment)

Assignee

Description

10 years ago
Starting a custom Sunbird 1.0pre build based on the 1.9.2a1pre branch (instead of the 1.9.1 branch) shows the following error:

Error: [Exception... "'[JavaScript Error: "setting a property that has only a getter" {file: "chrome://calendar/content/calendar-task-tree.xml" line: 1011}]' when calling method: [calIOperationListener::onOperationComplete]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///E:/sunbird/components/calCompositeCalendar.js :: anonymous :: line 550"  data: yes]

The task list remains empty. Previously created tasks are not shown.
I'm copying here what I already posted at bug 480383 comment #2 dated 2009-02-27 11:18:50 PST, since apparently it applies equally to this bug:

> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090227
> Calendar/1.0pre
>
> I'm seeing this too, on Linux. Calendar list is empty, all events are there,
> but displayed on white background instead of their respective *.ics calendars'
> colours. (I use several local *.ics files outside my profile, one read-only on
> the Web, no implicit "default" calendar.)
>
> Displaying an event's properties shows the appropriate calendar's name, but
> the calendar itself cannot be accessed.
>
> Yesterday's nightly didn't have the problem.
>
> Error console contains the following immediately after startup:
>
> Error: setting a property that has only a getter
> Source File: chrome://calendar/content/calendar-task-tree.xml
> Line: 1049
> --- (20 times, two at a time, with Javascript errors in between)
>
> Error: [Exception... "'[JavaScript Error: "setting a property that has only a
> getter" {file: "chrome://calendar/content/calendar-task-tree.xml" line:
> 1049}]' when calling method: [calIOperationListener::onOperationComplete]" 
> nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" 
> location: "JS frame :: file:///usr/local/sunbird/components
> /calCompositeCalendar.js :: anonymous :: line 550"  data: yes]
> --- (11 times, each of them except the last [in First > Last order]
> immediately after two of the above)
>
>
> If this is a different bug, please say so in a comment and set the platform
> back to Windows, I'll register a Linux bug in that case.
>
> This is a no-go for me, I'm going back to yesterday's nightly until it's
> fixed.

The build in question was, at the time, the latest Linux nightly from ftp://ftp.mozilla.org/pub/mozilla.org/calendar/sunbird/nightly/latest-trunk/. Its UA string (copy-pasted from Help=>About) is at the top of the pasted text above.
OS: Windows XP → All

Comment 2

10 years ago
I can confirm this occurring with me as well using nightly from 2009-02-28.
Assignee

Comment 3

10 years ago
After updating Thunderbird I can now confirm on 1.9.1 branch too.

Probably a core patch that landed on trunk before has now landed on the 1.9.1 branch too causing the error in Sunbird/Lightning.

Regression range: 
Works in Thunderbird 3.0b3pre (20090226032557) + Lightning 1.0pre (20090226)
Fails in Thunderbird 3.0b3pre (20090227093503) + Lightning 1.0pre (20090226)
Severity: minor → major
Flags: blocking-calendar1.0?
Keywords: regression
Summary: JavaScript Error: "setting a property that has only a getter" in calendar-task-tree.xml → Task list and task view are empty [JavaScript Error: "setting a property that has only a getter" in calendar-task-tree.xml]
Assignee

Comment 4

10 years ago
Checkins during regression range:
https://hg.mozilla.org/releases/mozilla-1.9.1/pushloghtml?startdate=2009-02-26+03:25:00&enddate=2009-02-27+09:36:00

I think the checkin for Bug 478047 revealed an error in the task list code.
Assignee

Comment 5

10 years ago
According Bug 478047 assignments to a property that has a getter but no setter were silently ignored and had no effect at all. Therefore it is save to just remove the line because it doesn't seems required at all.
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #364676 - Flags: review?(philipp)
Flags: blocking-calendar1.0? → blocking-calendar1.0+

Updated

10 years ago
Blocks: 478047
Comment on attachment 364676 [details] [diff] [review]
remove superfluous assignment that does nothing

r=philipp
Attachment #364676 - Flags: review?(philipp) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/d8e86c232bbc>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090303 Calendar/1.0pre

This is not the nightly, but the build from http://ftp.mozilla.org/pub/mozilla.org/calendar/sunbird/tinderbox-builds/comm-central-sunbird-linux/1236095292/ dated 2009-03-03 07:56 PST.

Symptoms described in comment #1 have disappeared (calendars are visible again, event colors are according to calendar again, and error console is empty).

I suppose this counts as the VERIFY step for Linux. I'm not setting VERIFIED yet, pending verification on other platforms.
This is a cross-platform issue, so linux should be sufficient. Thanks for checking!
Status: RESOLVED → VERIFIED

Comment 10

10 years ago
For me the task list is still empty.
Using: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.4pre) Gecko/20091014 Fedora/3.0-2.8.b4.fc11 Lightning/1.0pre Thunderbird/3.0b4
I don't see any logging in the error console.
Assignee

Comment 11

10 years ago
(In reply to comment #10)
You are most probably not seeing the issue reported here but a different one.
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.