PNG Image Display Problem (Yellow Overlay)

RESOLVED DUPLICATE of bug 460629

Status

()

RESOLVED DUPLICATE of bug 460629
10 years ago
10 years ago

People

(Reporter: rgolds, Unassigned)

Tracking

1.9.1 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2

A yellow overlay incorrectly appears over a CSS image link in Firefox 3.1b2 (does not happen in 3.0.6). Check http://www.chronowake.net/ for an example. The CSS relating to this image is as follows:

#header {
background: #73a0c5 url('images/newsheader.png') no-repeat bottom center;
}

#header a {
display: block;
height: 122px;
width: 759px;
text-decoration: none;
}

(Full CSS: http://www.chronowake.net/news/wp-content/themes/chronowake/style.css )

An unsightly yellow layer appears.

Reproducible: Always

Steps to Reproduce:
Create a CSS image link as described in the details.
Actual Results:  
An unsightly yellow layer appears.

Expected Results:  
The image should integrate properly in the page, as it does in Firefox 3.0.6, Internet Explorer, Safari, Chrome, etc.
(Reporter)

Comment 1

10 years ago
Created attachment 363242 [details]
Screenshot of the incorrect yellow overlay

Comment 2

10 years ago
Works for me on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
No yellow overlay, looks identical to Safari, Chrome, Opera, etc.

Perhaps you could upload a reduced testcase to this bug in case the site code changes?
(Reporter)

Comment 3

10 years ago
I've uploaded a screenshot: https://bugzilla.mozilla.org/attachment.cgi?id=363242

I just did a fresh installation of Firefox 3.1b2 with no addons, themes, etc. I can't imagine why it would only be happening for me?

Comment 4

10 years ago
Works for me - Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090217 Shiretoko/3.1b3pre

See the issue in beta 2, would would you check if a more recent build fixes the issue http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-1.9.1/
(Reporter)

Comment 5

10 years ago
Installed the latest nightly build; same problem confirmed to still exist.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.1 Branch
(Reporter)

Comment 6

10 years ago
The same yellow overlay problem occurs here:

http://www.chronowake.com/index.html

This header is not a link. The CSS associated with the header is:

#header {
	width: 562px;
	height: 60px;
	background: #000000 url(header.png) no-repeat;
	padding-top: 30px;
	padding-left: 18px;
	font-size: 14pt;
	color: #FFFFFF;
}

(Full CSS: http://www.chronowake.com/style.css )

Again, this yellow overlay problem occurs only in the newest versions of Firefox. In prior versions of FF, current versions of IE, Opera, Safari, Chrome, and other browsers, the header images appear normally. It seems like this may be associated with simply using a background image in a CSS div.

I've submitted another screenshot.
(Reporter)

Comment 7

10 years ago
Created attachment 363251 [details]
Another screenshot of the yellow overlay problem of a CSS background image
(Reporter)

Comment 8

10 years ago
Created attachment 363252 [details]
Same screenshot as above, but in JPG format
Attachment #363251 - Attachment is obsolete: true
(Reporter)

Updated

10 years ago
Summary: CSS Image Link Display Problem → CSS Background Image Display Problem (Yellow Overlay)

Comment 9

10 years ago
Sounds like a problem with Color Management, probably a bad monitor profile.
(similar to bug 460629 ?)

The image claims to have an sRGB profile embeded.
http://web.chronowake.com/header.png

Does it happen if you set to 'gfx.color_management.mode' in about:config to '0' ?
If you set it to '1', the whole page background may turn yellow.
(Reporter)

Comment 10

10 years ago
Bug still exists with gfx.color_management.mode set to 0. Changing this option doesn't have any noticeable effect.
(Reporter)

Updated

10 years ago
Summary: CSS Background Image Display Problem (Yellow Overlay) → PNG Image Display Problem (Yellow Overlay)
(Reporter)

Comment 11

10 years ago
Another update...

It appears that *all* PNG files appear in Firefox 3.1b2 (and the latest nightly build) with a yellow overlay. For another example, refer to the following page:

http://vip.wharton.upenn.edu/companies/ChronoWake.html

The latest builds of Firefox display the PNG with a yellow overlay. Firefox 3.0.6 (and every other browser I've tested) displays these PNG images properly.
Ryan - just to confirm - did you restart firefox after setting gfx.color_management.mode to zero? The setting requires restarting the browser to take effect.
(Reporter)

Comment 13

10 years ago
Changing gfx.color_management.mode to 0 did work! The problem is that for some reason, the default for this setting is 2, which causes that weird yellow overlay on PNGs... so I guess the 'fix' would be to have the default for gfx.color_management.mode set as 0 instead of 2.

Thanks Bobby!

Comment 14

10 years ago
(In reply to comment #13)
> Changing gfx.color_management.mode to 0 did work! The problem is that for some
> reason, the default for this setting is 2, which causes that weird yellow
> overlay on PNGs... so I guess the 'fix' would be to have the default for
> gfx.color_management.mode set as 0 instead of 2.

That means that for some reason the color profile used for your monitor is bad or deficient.

1. could you attached that profile here (zipped up) for further inspection ?
2. Check the manufacturers website for your monitor to see if they have updated profiles
(Reporter)

Comment 15

10 years ago
I haven't changed the color profile from the system default. The monitor I have is a Dell 1907FP (Digital), Windows Vista Enterprise, nVidia 8400GS graphics card. The fact that this problem only occurs with the latest versions of Firefox (and not with 3.0.6 or the current versions of any other browser I've tested) seems to indicate that this is a problem that should be remedied in the default Firefox settings.

I'm sure I'm not the only person with this problem, as everything I have is at their system default values (new computer, haven't customized it yet).
>The fact that this problem only occurs with the latest versions of
>Firefox (and not with 3.0.6 or the current versions of any other browser I've
>tested) seems to indicate that this is a problem that should be remedied in the
>default Firefox settings.

enable the color management in FF3.0.6 which is off by default and I bet you get the same issue.

>I'm sure I'm not the only person with this problem, as everything I have is at
>their system default values (new computer, haven't customized it yet).
I assume that Dell added the broken color profile for their monitor to the installation.

Please follow comment #14 and attach the profile
Component: General → GFX: Color Management
Product: Firefox → Core
QA Contact: general → color-management
Version: 3.1 Branch → 1.9.1 Branch
(Reporter)

Comment 17

10 years ago
Created attachment 363454 [details]
1907FP.icm color profile, possibly causing yellow overlay of PNG files with Firefox color management enabled

The full contents of the %WINDIR%\System32\Spool\Drivers\Color\ directory, zipped, with 1907FP.icm as the profile set on the system.
CCing chris murphy.

Chris - what's your take on this profile? I thought that our bogus profile checks should have taken care of all of these white->yellow issues.

Comment 19

10 years ago
1. 1907FP.icm's creation date is 9/23/05, and the copyright tag is:
Copyright(C) 2003 Win-Global Technology Inc.

This is not a profile created on the fly by Windows Vista (which I don't think it does anyway) from EDID. I do not understand how this profile could be set as the system display default profile without user intervention. Is it possible that Dell has a very specific installation of Windows Vista that knows this exact display is going to be used, and they install the profile and set it by default with their own in-factory installation process? It seems to be rather unlikely.

2. The profile contains either unadapted or incorrectly adapted RGB primaries. The RGB XYZs don't add up to D50 white per the ICC spec. They should add up to:
0.9640	1.0000	0.8250

Yet they are:
0.9390	0.9910	1.1500

I don't recall exactly what fix we came up with for this, but wasn't it something about testing for ensuring the primaries are properly adapted by adding up their XYZ's, and then assuming some kind of threshold? If that's what we did, then we need to look at the threshold function for disqualifying the display profile, and tightening the threshold perhaps. Maybe it was made too loose.

Maybe a threshold of +- 0.1 would be *A LOT* and would allow the R and G primaries to pass (even though the red one is off by too much), but would still certainly fail the blue primaries, which is really way way off and why we're seeing a yellow cast being added.

So maybe by tightening the tolerance, we are in fact being MORE conservative by increasing the disqualification rate and going with sRGB instead of the set display profile.

Comment 20

10 years ago
Didn't we come up with +- 3 in either L*, a*, or b* for disqualification? That's what is being used in Photoshop. So somehow, this profile which is definitely outside of 3 b* from what it should be, is not being rejected and I don't know why that would be the case.

The delta in just blue is 23, so it should have failed, and been rejected.
http://mxr.mozilla.org/mozilla-central/source/modules/lcms/src/cmsio1.c#2529

That's our criterion. Seems like it should have been rejected.
OH! I just realized that the poster is running beta2 and not a nightly. That would explain it perfectly.

Ryan, I believe this problem was fixed after beta 2 was rolled. Can you try out one of the nightlies (http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/) and see if it goes away?

Thanks. Sorry for the confusion.

Comment 23

10 years ago
Threshold function is very close to that of Photoshop. So I'm fine with it as is. It's baffling how manufacturers have produced such sloppy profiles. Jeez.
(Reporter)

Comment 24

10 years ago
(In reply to comment #22)
> OH! I just realized that the poster is running beta2 and not a nightly. That
> would explain it perfectly.
> 
> Ryan, I believe this problem was fixed after beta 2 was rolled. Can you try out
> one of the nightlies
> (http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/) and see
> if it goes away?
> 
> Thanks. Sorry for the confusion.

I can confirm that this bug is fixed in the latest nightly. I ensured the default gfx.color_management.mode setting, and upon loading any of the pages that used to have this problem, the yellow overlay no longer exists.

Thanks! I'm happy to see that this has been fixed before the final release. If anyone else wants to check using the color profile I loaded, please do so. Otherwise, feel free to close this bug.
Note: the new build just ignores your broken color profile
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Resolving as duplicate of bug 460629.

Thanks for your help Ryan and Chris.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 460629
You need to log in before you can comment on or make changes to this bug.