crash when reloading a page with a Java applet accessed from Javascript using Liveconnect and the "old generation" Java plugin

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: Tomas Styblo, Unassigned)

Tracking

({crash, stackwanted})

3.0 Branch
x86
Windows XP
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-01-25], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6

Firefox 3 on Windows with the "old generation" Java plugin crashes when reloading a page with any Java applet accessed from a Javascript body.onload handler using Liveconnect.

The problem does not happen with the "new generation" Java plugin. It also does not happen with Firefox running on Linux. Internet Explorer is also not affected by this. 

The crash happens when obtaining a reference to the Applet object from a Javascript body.onload handler using document.appletname, getElementById() or document.applets[], while reloading the page. Firefox crashes in xul.dll, probably because of a race condition.

The applet at the test URL is just a stub that does not do anything. The problem happens with any applet.

Reproducible: Always

Steps to Reproduce:
1. disable the "new generation" Java plugin in Control Panel/Java/Advanced, or just use Java 1.5
2. try quickly reloading the test page a dozen times
3.
Actual Results:  
Firefox crashes.

Expected Results:  
No crash.

Using default theme. No extensions. Crashes with both Java 1.5 and 1.6.

Comment 1

8 years ago
can you reproduce in FF 3.5 or higher
if you can reproduce, a stack trace is needed
https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report
Severity: major → critical
Keywords: crash, stackwanted
Whiteboard: [closeme 2010-01-25]
Version: unspecified → 3.0 Branch

Comment 2

8 years ago
Firefox no longer uses the old Java Plugin, Java 6 u10 is required to use Java with Firefox 3.6.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.