fails to open a local file from explorer, if mozilla is already started

RESOLVED FIXED

Status

()

P5
critical
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: ali, Unassigned)

Tracking

Trunk
x86_64
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6

If I use Mozilla online or offline (Mozilla is started), I sometimes want to open a local file (e.g. Bookmarks.html) from explorer. Mozilla fails to open local files, if I dobbleclick on it or select from popup-menue 'open with Mozilla'.
Open a local file works only from Mozilla->menu->file->open or even from explorer, but only if mozilla is not started already.
Drag'n'Drop works.

Reproducible: Always

Steps to Reproduce:
1. Start Mozilla Firefox
2. Start explorer
3. select a local html-file(xy.htm) (or a link on a html file (xy-html.lnk))
4. open selected file by dobble-click on it or by selecting in popup-menu 'open with .. Firefox
Actual Results:  
nothing happens

Expected Results:  
Mozilla Firefox opens the selected file in main window or in a new tab or in a new window

Drag'n'drop works.
My files are correct linked to firefox.
The same actions, I described, work with MS-Internet-explorer -> it starts a new window
Component: MozillaBuild → General
Product: mozilla.org → Firefox
QA Contact: mozillabuild → general
Version: other → Trunk
(Reporter)

Updated

10 years ago
Severity: normal → major
(Reporter)

Comment 1

10 years ago
Program-Helpfiles are often in HTML and cannot be used simultaneously with opened Mozilla browser, oddly.
(Reporter)

Comment 2

9 years ago
in the last version, too.
--> Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
(Reporter)

Comment 3

9 years ago
in the last version, too.
--> Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

Found the source of this problem:
>>> automatic generated win-explorer-link generated by firefox itself is:
(1)"C:\Programme\Mozilla Firefox\firefox.exe" -requestPending -osint -url "%1"
and does not work!
If I change the link in "firefox.exe %1" it works BUT, firefox.exe says
it is not the "standard browser".
As soon I confirm the firefox to be the standard browser it change the explorer-link to (1) again, .. and this problem appears, again!<<<

Does anybody use offline-html files ?(:<
Severity: major → critical
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Priority: -- → P5
Resolution: --- → FIXED
(Reporter)

Updated

9 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Updated

9 years ago
Status: VERIFIED → UNCONFIRMED
Resolution: FIXED → ---
(Reporter)

Comment 4

9 years ago
Fixed in
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.