If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

xul:button type="checkbox" does not change its appearance when checked in Windows

RESOLVED DUPLICATE of bug 437009

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 437009
9 years ago
9 years ago

People

(Reporter: atte, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

501 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.6) Gecko/2009011912 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.6) Gecko/2009011912 Firefox/3.0.6

xul:button type="checkbox" does not change its appearance when checked in Windows. This works just fine in Linux. Mac, I don't know. Using default theme.

Reproducible: Always

Steps to Reproduce:
1. Click xul:button type="checkbox" so that it's checked

Actual Results:  
In Windows, button looks the same whether it's checked or not.

Expected Results:  
Button should change its appearance. In Linux, button's color is changed to a darker color. Note that you need not hover, to see the change.
(Reporter)

Comment 1

9 years ago
Created attachment 363321 [details]
simple test case
I can confirm this with the default theme of Fx (3.0.6).
But when using Nasa Night Launch theme, the appearance of the button changes.

Seems to be a missing css definition for button in the default theme?
(Reporter)

Updated

9 years ago
Component: General → Theme
Version: unspecified → 3.0 Branch
Seems to work for me with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090220 Minefield/3.2a1pre
The tested build can be downloaded here: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 437009
You need to log in before you can comment on or make changes to this bug.