Preference window created too narrow

VERIFIED FIXED in M7

Status

P3
normal
VERIFIED FIXED
20 years ago
14 years ago

People

(Reporter: mcmullen, Assigned: matt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
This may be the same bug as the one that broke mailnews. It is definitely a
regression since yesterday.

Edit/Preferences still brings up a window, but it is no longer drawn correctly.
The frame that should be on the right is plonked at full size over the entire
window.
(Reporter)

Updated

20 years ago
Priority: P3 → P1
Target Milestone: M4

Updated

20 years ago
Component: Apprunner → HTMLFrames
QA Contact: 3853 → 3849

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED

Comment 1

20 years ago
Same bug as for mail-news...I backed out the one line change for
nsViewManager.cpp...fixed

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 2

20 years ago
using 1999042108 build, marking verified

Updated

20 years ago
Status: VERIFIED → REOPENED
Preference window now brings up Category list box on top of description where it
should be side-to-side. Build 1999051408. IanHolsman@iname.com
Priority: P1 → P2
Resolution: FIXED → ---
Summary: Right hand frame in preferences window drawn on top of window → reference window brings up category list box
Target Milestone: M4
[updating summary to match description]
[clearing resolution]
[reducing priority, P1 is for crashers on Kipp's bug list]
[dbaron: removed milestone so that we can verify this bug]

Is this an HTML Frames bug? If so it should be reassigned to the owner
of the selected component. If not, then it should be reassigned to the
relevant component, probably Prefs UI or Apprunner.
Assignee: kipp → shuang
Status: REOPENED → NEW
Component: HTMLFrames → Pref UI
OS: Mac System 8.5 → All
Priority: P2 → P3
Summary: reference window brings up category list box → Preference window created too narrow
This is not a layout bug. As far as I can tell, the problem is simply that the
prefs window is created too small. Make the window wider by a few pixels and it
displays ok.

Reassigning to pref ui component.

Updated

20 years ago
QA Contact: 3849 → 4137

Comment 6

20 years ago
still a big problem in the 1999052008 build - lots of text goes missing!

Comment 7

20 years ago
matt is working on pref. reassign it to matt for fixing, cc german if need spec.

Updated

20 years ago
Assignee: shuang → matt

Comment 8

20 years ago
matt is working on pref. reassign it to matt for fixing, cc german if need spec.

Updated

20 years ago
Target Milestone: M7

Comment 9

20 years ago
Move to M7 ...
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

20 years ago
This was fixed by me a few days ago

Updated

20 years ago
Status: RESOLVED → REOPENED

Comment 11

20 years ago
using the 1999052008 build under nt, this is most definitely not fixed.
reopening bug. (to verify this, launch apprunner and open the prefs. you can't
see everything unless you manually resize the window.) was the fix checked in?

Updated

20 years ago
Resolution: FIXED → ---
(Assignee)

Updated

20 years ago
Status: REOPENED → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

20 years ago
This is fixed now

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 13

20 years ago
OK, I think; the prefs window is messed up badly in other areas but I think it's
the correct width now. Build 1999061108, NT.
(Reporter)

Comment 14

20 years ago
It's messed up because it's in XUL, now.

Comment 15

19 years ago
Bulk move of all Pref UI component bugs to new Preferences component.  Pref UI 
component will be deleted.
Component: Pref UI → Preferences
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.