no file dialog appears when downloading pdf

VERIFIED FIXED

Status

()

Core
Networking
P3
major
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Kristian E. Markon, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m17) Gecko/20000807
BuildID:    ??? M17

When I click on a link to download a pdf file, such as at
http://lib.stat.cmu.edu/R/CRAN/doc/packages/fdim.pdf (but at other sites as
well) the browser appears to download the file (the progress indicator in the
bar on the bottom of the browser appears until it says "Document: Done (x secs)").

However, no file dialog appears, or at least unless:

If I go to another link, and use the back button to return to the download link,
the file dialog will then appear.

e.g,

I click on http://lib.stat.cmu.edu/R/CRAN/doc/packages/fdim.pdf
and the browser appears to download fdim.pdf, but no dialog appears.

If I then click on
http://lib.stat.cmu.edu/R/CRAN/src/contrib/Descriptions/fdim.INDEX
and click on the back button, a dialog will appear for fdim.pdf.

I have reproduced this with other pdf files at other sites.

It seems similar to bug 9897.

Reproducible: Always
Steps to Reproduce:
1. click on .pdf download link
2. go to other link
3. hit back button

Actual Results:  file save/action dialog appears

Expected Results:  dialog should appear when first clicking on download link

Updated

18 years ago
Assignee: gagan → law

Comment 1

18 years ago
I think there is adup for this somewhere. Law would know. 

Comment 2

18 years ago
Could not find this reported.  Setting bug status to New
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
This is fixed now and is working for me using todays build: 09/01 on Win NT
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 4

18 years ago
Works for Me
Platform: PC
OS: Windows 98
Mozilla Version: 2000100508

Marking as Verified

Comment 5

18 years ago
marking verified per Keysers comments
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.