replace http://addons.mozilla.org with SITE_URL

RESOLVED INVALID

Status

addons.mozilla.org Graveyard
Public Pages
--
enhancement
RESOLVED INVALID
9 years ago
2 years ago

People

(Reporter: David Farning, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.6) Gecko/2009020911 Ubuntu/8.10 (intrepid) Firefox/3.0.6
Build Identifier: svn HEAD

I thought that I would start with some lower hanging fruit.

This patch replaces the string 'http://addons.mozilla.org' with the constant SITE_URL as defined in config.php.

In each instance the string refers to the actual site URL so no translation is needed.

This patch is limited to .thtml files.

Reproducible: Always
(Reporter)

Comment 1

9 years ago
Created attachment 363410 [details] [diff] [review]
Replace-hardcoded-a.m.o-with-SITE_URL
Attachment #363410 - Flags: review?
Summary: replace http://addons.mozilla.org with SITE_NAME → replace http://addons.mozilla.org with SITE_URL
Comment on attachment 363410 [details] [diff] [review]
Replace-hardcoded-a.m.o-with-SITE_URL

Nothing in /facebook views should be modified. Keep in mind that some parts of AMO are not served from addons.mozilla.org but instead from another installation at services.addons.mozilla.org or facebook.addons.mozilla.org, and therefore SITE_URL is not always the same as a link to addons.mozilla.org.
Attachment #363410 - Flags: review? → review-
(Reporter)

Comment 3

9 years ago
This patch only affect the string 'http://addons.mozilla.org'.  'services.addons.mozilla.org', 'facebook.addons.mozilla.org' and even 'addons.mozilla.org' are untouched.

There is a SERVICES_URL defined in config.php for services.addons.mozilla.org.

Why should /facebook be left unmodified?
If a copy of AMO is running on the domain facebook.addons.mozilla.org, the SITE_URL will be facebook.addons.mozilla.org.

So changing the links there that go to addons.mozilla.org to SITE_URL is not appropriate. If they were changed to SITE_URL, the links would go to facebook.addons.mozilla.org, which is not what's intended. They have to go to addons.mozilla.org.
(Reporter)

Comment 5

9 years ago
Ok got it.

I did not realize that you were already running facebook.addons.mozilla.org as a sub site of addons.mozilla.org.

I will rethink how to handle this patch.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.