aNotification is null in _showNotification() in bindings/notification.xml

RESOLVED WORKSFORME

Status

()

Toolkit
XUL Widgets
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Matthew Cline, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.8pre) Gecko/2009022006 GranParadiso/3.0.8pre ID:2009022006

When installing the latest Console^2 from http://downloads.mozdev.org/console2/console2-0.3.10.xpi via http://console2.mozdev.org/ , I got an error in the error console about "aNotification is null" in bindings/notification.xml.  FireFox crashed while I was writing the bug report, so I don't have an exact copy of the error message, and LXR shows _showNotification() being in mozilla/toolkit/content/widgets/notification.xml rather than in bindings/notification.xml, but I rember show source showing the the error happened at http://mxr.mozilla.org/mozilla/source/toolkit/content/widgets/notification.xml#205:

    var height = aNotification.boxObject.height;


This error didn't seem to cause any problems in installing the xpi file.
That error could be caused by someone calling removeCurrentNotification() when no notification had been displayed yet. Does that extension do that?
(Reporter)

Comment 2

9 years ago
> Does that extension do that?

I don't know, sorry.

Comment 3

9 years ago
(In reply to comment #2)
> I don't know, sorry.

Easy to find out: Disable the extension and see if the error still appears in similar circumstances.

Then, if you can't reproduce the issue without the extension installed, please file a bug against the extension in its own bug tracker (in your case at <http://console2.mozdev.org/bugs.html>), so that the extension's author can decide if the bug is in his code or in ours.

AFAICT, Console² doesn't use notifications, though...

Gavin: Even though I'm still listed as Console²'s author, Philip Chee has been so kind to do all the work for maintaining and updating it during the last two years.

Comment 4

9 years ago
> AFAICT, Console² doesn't use notifications, though...
Confirmed, we don't use notifications.
(Reporter)

Comment 5

9 years ago
I upgraded from 3.1pre to 3.2a1pre before I saw the request to duplicate, and can no longer duplicate it, but since the error happened when doing an upgrade the steps I took were:

1) Uninstalling Console² and restarting.
2) Installing version 0.3.9.2 and restarting.
3) Installing version 0.3.10

That caused no problems.

Comment 6

9 years ago
OK Based on Comment #5 resolving as WORKSFORME. Please reopen if this crops up again. Thanks.

>> AFAICT, Console² doesn't use notifications, though...
> Confirmed, we don't use notifications.

But browser.xul and extensions.xul do. Perhaps co-incidentally something else was trying to remove a notification in one of those windows.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.