If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

findCluster should run only when server is s.m.c

RESOLVED INVALID

Status

Cloud Services
General
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: anant, Unassigned)

Tracking

unspecified
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Currently the Weave client uses the API on services.mozilla.com to fetch a cluster name to connect to. This will break users who are setting up their own Weave server.

One possible solution is to use findCluster only if the serverURI is auth.services.mozilla.com. Ideas?

Comment 1

9 years ago
No, it won't break.  If the server returns a 404 for chknode, the client will assume the cluster == server.  So the scenarios are:

1) server is auth.services.mozilla.com

-> chknode will return user's cluster, client will use that.

2) server is a personal one, does not have chknode

-> client will use the personal server as the cluster

3) server is a personal one, does have chknode

-> client will follow chknode as it would for auth.s.m.c

So this is not a bug.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Updated

8 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
Version: 0.3 → unspecified
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.