Closed Bug 479628 Opened 11 years ago Closed 11 years ago

Tearing off tabs is too sensitive, dragging a tab onto itself causes tear-off

Categories

(Firefox :: Tabbed Browser, defect)

3.5 Branch
x86
Windows 7
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 465346

People

(Reporter: netrolller.3d, Unassigned)

Details

The "tear off tabs into separate windows by dragging" feature is way too sensitive in Fx3.1b2, accidentally dragging a tab a few pixels (instead of clicking it) without leaving the boundary of the tab (so that a "NO" cursor is shown) already causes the tab to detach. I often find myself accidentally detaching tabs, and having to re-attach them by hand to my main browser window.

I suggest that only drags that go outside the tab bar should detach the tab, "drag-to-self" definitely shouldn't.

Steps to reproduce:
1. Open 2 tabs.
2. Click the first tab.
3. Click and hold the center of the second tab.
4. Drag the mouse ~10px to the left, without triggering a tab reorder.
5. Release the mouse. The tab detaches.

Even more annoying version:
1. Open 2 tabs.
2. Click the first tab.
3. Start dragging the second tab, as if you want to reorder the tab.
4. Before dropping the tab, drag it back to itself (as if you wanted to cancel the drag).
5. Release the mouse. The tab detaches.
Flags: wanted-firefox3.1?
Flags: blocking-firefox3.1?
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 465346
v.
Status: RESOLVED → VERIFIED
Removing blocking flags as this is a straight dupe.
Flags: wanted-firefox3.1?
Flags: blocking-firefox3.1?
You need to log in before you can comment on or make changes to this bug.