Dropping "Most Visited" of Bookmark Toolbar to Search bar causes privacy disclosure

RESOLVED WONTFIX

Status

()

--
minor
RESOLVED WONTFIX
10 years ago
6 years ago

People

(Reporter: masa141421356, Unassigned)

Tracking

({privacy})

Trunk
x86
All
privacy
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090222 Firefox/3.1b2pre

Steps to reproduce
1.Drag "Most Visited" to seach box

Actual Result
 List of your "Most Visited" websites is disclosed to search engine provider.

Excepcted behavior
 Lst of "Most Visited" websites should not disclosed to  search engine provider.
(Reporter)

Comment 1

10 years ago
Dropping folder to Search box is ignored.
I think, Dropping "Most Visited" (and also "Recent Tags" and "Recent bookmarked") should be ignored.
Summary: Dropping "Most Visited" of Bookmark Toolbar to Textbox causes privacy disclosure → Dropping "Most Visited" of Bookmark Toolbar to Search bar causes privacy disclosure

Comment 2

10 years ago
I can reproduce with trunk Linux build.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090224 Minefield/3.2a1pre
OS: Windows XP → All
I don't think there's a privacy problem here, since you explicitly drag a container to a search field. containers (either queries or folders) provide a text flavor to be able to drag them a text field in a form, a textarea, or just a text editor.
This bug looks like requesting a lots of special casing for an eventual privacy hit that in reality can hardly happen. The cost is not worth the benefit.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.