Software Update not available on Vista if path to Firefox is not under Program Files [@ UpdateService:canUpdate]

VERIFIED DUPLICATE of bug 318855

Status

()

defect
VERIFIED DUPLICATE of bug 318855
10 years ago
10 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

1.9.1 Branch
All
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090221 Shiretoko/3.1b3pre Ubiquity/0.1.5 ID:20090221020541

If Firefox is called via a path which contains a symlink the software update is grayed out inside the help menu. That happens due to missing permissions. As result canUpdate fails:

AUS:SVC UpdateService:canUpdate - unable to update. Exception: [Exception...
"Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)
[nsIFile.create]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)" 
location: "JS frame ::
file:///C:/Programme/Mozilla%20Firefox%203.1/components/nsUpdateService.js ::
anonymous :: line 1607"  data: no]

Steps:
1. Do a normal installation of Firefox
2. Create a symlink which points to "C:\Program Files" (see bug 456895)
3. Call Firefox via this symlink
Summary: Software Update not available if path of Firefox contains a symlink [@ UpdateService:canUpdate] → Software Update not available if path of Firefox contains a symlink with limited permissions [@ UpdateService:canUpdate]
This happens because the path is not under program files which is required on Vista to prompt for elevation. We might be able to just check if the user is a member of the admin group and not care if the path is under program files.
note: the error is an expected / handled exception for this case
Summary: Software Update not available if path of Firefox contains a symlink with limited permissions [@ UpdateService:canUpdate] → Software Update not available on Vista if path to Firefox is not under Program Files [@ UpdateService:canUpdate]
This is a dupe of the other bugs to provide the ability to update when outside of program files on Vista or for that matter anywhere when running as a limited user on Win2K / XP which is bug 318855
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 318855
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.