Calendar/task shortcut buttons are not available if the tabbar is hidden (after setting "mail.tabs.autoHide" to true)

RESOLVED DUPLICATE of bug 515802

Status

RESOLVED DUPLICATE of bug 515802
10 years ago
9 years ago

People

(Reporter: Aureliano, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.9.1b3pre) Gecko/20090214 Shiretoko/3.1b3pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090218 Lightning/1.0pre Thunderbird/3.0b2 ID:20090218180609

Set mail.tabs.autoHide = true, toolbar with lightning calendar and tasks, not is show if I have only one tab.


Reproducible: Always



Expected Results:  
Lightning calendar and tasks buttons should be show every time, also when I have only one tab and mail.tabs.autoHide=true.
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk
Component: Toolbars and Tabs → General
Product: Thunderbird → Calendar
QA Contact: toolbars-tabs → general

Comment 1

10 years ago
I'm not really sure what we should do here. The tab bar was designed as our integration hook, so if someone hides it, this integration hook is obviously lost. 

Personally I still think that the two icons on the right of the tab bar are not obvious enough for a newbie user and that we should include those buttons in the redesigned toolbar instead.

Philipp, what do you think?
Component: General → Lightning Only
OS: Windows XP → All
QA Contact: general → lightning
Hardware: x86 → All
I think the idea was to introduce a half-height toolbar with calendar and task icons, though it was moved to an extension first, see [1]. Although a bit cludgy if mail.tabs.autoHide = true, we still have the menu and keyboard shortcut to get to calendar mode.

How is mail.tabs.autoHide set to true? Does the user have to do this himself, or is there some sort of UI-visible option? In the former case, I'd say we are good since if the user knows how to go in the advanced config editor and set values, then he'll also know how to get to calendar mode via menus.

I'd vote for WONTFIX in favor of tinkering with the minibar extension and maybe bringing that into core code at some point.

[1] http://hg.mozilla.org/users/mozilla_kewis.ch/minibar
> How is mail.tabs.autoHide set to true?

There's no UI, and I wouldn't expect any. If someone goes to the trouble of setting the hidden pref, I don't thing he's entitled to complain that his choice hides some functionality. That's what he asked for by setting the pref.
Summary: mail.tabs.autoHide = true on trunk and lightning → Calendar/task shortcut buttons are not available if the tabbar is hidden (after setting "mail.tabs.autoHide" to true)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

10 years ago
(In reply to comment #3)
> There's no UI, and I wouldn't expect any.
That's where I disagree...
Everytime I test another new Thunderbird 3 version, I am checking the functionality of the new tabs. As long as there's no options category "Tabs" (as it exists in Firefox), I will not start to use TB3 for production.

To my mind, there's no need for Tabs that are not usable or the ability to prefer Tabs instead of new windows - but that's not the question here.

I would really like to see a good suggestion to integrate Lightning into an grown-up Tab solution in Thunderbird.
I'm closing this bug in favor of bug 515802. Since this is currently a hidden setting, I don't think we should provide an automatic solution for it. Adding toolbarbuttons is an easy workaround if you prefer auto-hiding tabs.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 515802
You need to log in before you can comment on or make changes to this bug.