Start dragging in the margin of an element selects part of that element

VERIFIED WONTFIX

Status

()

Core
Editor
P4
enhancement
VERIFIED WONTFIX
18 years ago
17 years ago

People

(Reporter: jamacht, Assigned: mjudge)

Tracking

({helpwanted})

Trunk
Future
x86
Windows 98
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
The area between paragraphs should be dead area in regards to selection. 
Currently the 50% point between the paragraphs is the separator with regards to 
selection. 

Build: 2000080712 (M17)
Reproducability: always

Steps to reproduce:
1) Find any document with two consecutive paragraphs. There should be a one line 
space in between the two paragraphs.
2) Click once between the two paragraphs. 
3) Drag the mouse below the start of the second paragraph.
4) Observe results. 
5) Drag the mouse up, until it is within the first paragraph.
6) Observe results.

Results: Either:
   a) step 4 result in text from the first paragraph being selected or
   b) step 6 result in text from the second paragraph being selected

Expected Results: 
   Both paragraphs should not be selected simultaneously. The selection in Step 
4 should start with the beginning of paragraph 2. The selection in Step four 
should end at the end of paragraph 1.

Comment 1

18 years ago
confirming, win95 080908...what component is this?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
If the text is truly two paragraphs, then this occcurs. If the text is body text 
with br separators, this does not occur. Checked this out using the m18 build on 
win98 dated 8/9.

Starting with Joe to see what can be done about this, Joe if this needs to go to 
someone else, then please reassign.

Can you also set the priority
Assignee: beppe → jfrancis
Keywords: correctness, nsbeta3
Whiteboard: [nsbeta3+]
Target Milestone: --- → M18

Comment 3

18 years ago
talked with mjudge about this and the action that is happening is what is 
supposed to be happening. On windows, when the selection is set in between 
paragraphs, what actually gets selected will depend on the mouse movement. If 
you drag slightly upward, then the previous line will get selected starting from 
where you set the caret, if you select downward, the same will happen to the 
text below. The selection snaps to the appropriate text. As you drag, the 
selection will flow to the end of the line and will then immediately snap to the 
text above or below. The caret needs to snap to something when it is clicked, 
and that is what you are seeing.

I incorrectly set the whiteboard and keywords, removing them and marking as 
worksforme
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Keywords: correctness, nsbeta3
Resolution: --- → WORKSFORME
Whiteboard: [nsbeta3+]
(Reporter)

Comment 4

18 years ago
So, is it design that the caret gets placed initially where it does? I would 
prefer it be placed between the two paragraphs if that is possible, which is 
what NS does.

Selecting a complete paragraph becomes tedious. If I wanted to select the text 
on the previous line (from where the caret was inserted), I could do that, just 
like if I wanted to select text in the middle of a paragraph. If I want to 
select paragraphs, I have to very carefully position my cursor just before the 
first character in the paragraph. I think paragraphs are a little more important 
than the text in the paragraphs in terms of document structure.

If selecting downward started at the next line's selection point, and selecting 
upward started at the previous line's insertion point it would make more sense, 
but this is not what is happening.

IE does some horrible thing like always select the next line and place the caret 
there. Mozilla is very similar in this regard, but choosing the next or previous 
line based on the mouse position when clicked.
(Reporter)

Comment 5

18 years ago
Created attachment 12644 [details]
Two paragraphs with which to test selection
(Reporter)

Comment 6

18 years ago
I noticed another odd thing with drag select. I don't know if it has anything to 
do with this bug, though. If you start dragging down  on the left side of the 
'S'  in the second paragraph of the test case (it has to be above the middle of 
the line), it starts selecting from the previous line. This is undoubtedly 
incorrect behavior, and i'll file another bug if necessary.

Comment 7

18 years ago
verified in 8/10 build.
Status: RESOLVED → VERIFIED

Comment 8

18 years ago
I discused this bug with jamacht@pobox.com in the IRC. I understand the problem
is that when we make a selection, the selection starts in the element(<p> in
this case) the mouse is over, including the marging of the element; technically
I think that is right; but seems some people thinks that this make hard
selecting paragraphs without catching a bit of another paragraph.

In my opinion the solution might be ignore the margin for making selections and
don't consider it part of the element, but I don't know how hard it is to
implement, or if it may make difficult to make selections in other cases.

Anyway in my opinion this isn't very critical so I reopen this bug but mark it
as enhancement(what I think it is) and set target to future.

Putting 4xp keyword because jamacht@pobox.com says selection doesn't work the
way netscape 4.x did(can't confirm because I don't have NS 4.x installed).

Changed the Summary to: "Start dragging in the margin of an element selects part
of that element" for clarity.
Severity: normal → enhancement
Status: VERIFIED → REOPENED
Keywords: 4xp
Priority: P3 → P4
Resolution: WORKSFORME → ---
Summary: Drag Select between paragraphs selects previous or next line → Start dragging in the margin of an element selects part of that elementStart dragging in the margin of an element selects part of that element
Target Milestone: M18 → Future

Updated

18 years ago
Summary: Start dragging in the margin of an element selects part of that elementStart dragging in the margin of an element selects part of that element → Start dragging in the margin of an element selects part of that element

Comment 9

18 years ago
adding helpwanted
Keywords: helpwanted
(Reporter)

Comment 10

18 years ago
This doesn't happen on the Macintosh, latest M18 build 2000081504. Confirmed 
with today's 2000081508 win32 build.

On the Macintosh, selection doesn't occur while dragging horizontally between 
paragraphs w/ mouse button down if the cursor is the normal pointer. As soon as 
the cursor changes to vertical bar cursor, selection occurs. I beleive this is 
correct behavior. 

On Windows 98, selection occurs regardless of the state of the cursor in the 
above situation. 

Comment 11

18 years ago
i'm not the right man to own this non-bug
Assignee: jfrancis → mjudge
Status: REOPENED → NEW
(Assignee)

Comment 12

17 years ago
this aint getting fixed. NS4.x did a horrible thing and ripped apart all <P>s 
and made them BRs then made them BACK to <P> when it felt like it on output
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WONTFIX

Comment 13

17 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.