Ahem, CSS2.1 background-repeat test case fails.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
6 years ago

People

(Reporter: p.chwiej, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090223 Minefield/3.2a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090223 Minefield/3.2a1pre

Be sure that you have Ahem font installed.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.w3.org/Style/CSS/Test/CSS2.1/current/html4/t140201-c534-bgreps-02-c-ag.htm
Actual Results:  
There are some messy red lines all around the green rectangle.

Expected Results:  
Clean green rectangle visible.

Comment 1

10 years ago
It displays red lines rather evenly in the green rectangle.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.16) Gecko/20061201 Firefox/2.0.0.16 (Ubuntu-feisty)

Comment 2

10 years ago
On Windows, I can reproduce this on *all* browsers.. if I have ClearType (font smoothing) enabled. With font smoothing disabled, every engine shows a clear green box.

I remember there were bugs like this before, so it's likely a dupe; may even be invalid.
Keywords: testcase
OS: Linux → All
Hardware: x86 → All
Whiteboard: DUPEME, INVALID?
Version: unspecified → Trunk

Comment 3

6 years ago
Latest version of this test is:
http://test.csswg.org/suites/css2.1/latest/html4/c534-bgreps-002.htm

I created a reftest for it in /nightly-unstable 

http://test.csswg.org/suites/css2.1/nightly-unstable/html4/reference/c534-bgreps-000-ref.htm

and did not notice anything wrong or incorrect with the test:

http://test.csswg.org/suites/css2.1/nightly-unstable/html4/c534-bgreps-002.htm

Firefox 16.0.2 (navigator.buildID == 20121025212230) under Linux KDE 4.9.3 (i686: 32bits) with Kubuntu raring here.

WORKSFORME

-----------

Please note that font-size in the old test was changed from 14px to 20px on August 16th 2010 to avoid inaccurate baseline-alignment of Ahem glyphs because 14px is not dividable by 5px without creating remainder but 20px is!

See:
http://hg.csswg.org/test/diff/0219aab60a88ea422274a32ef4ca19b43b565e97/approved/css2.1/src/css1/c534-bgreps-002.xht

And the support file pattern-grg-rgr-grg.png was subsequently modified to reflect such 14px -> 20px change:

http://test.csswg.org/shepherd/support/pattern-grg-rgr-grg.png

So, Chwiej and Andrew most likely indeed saw red lines on 2009-02-23 and then the test and its support file were changed, improved on mid-august 2010.

Therefore, unless Chwiej and Andrew still see red lines, I am for resolving this bug as WORKSFORME

Gérard

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Updated

6 years ago
Whiteboard: DUPEME, INVALID?
You need to log in before you can comment on or make changes to this bug.