bugzilla scripts (whine.pl and collectstats.pl) are noisy because of a perl notice

RESOLVED WORKSFORME

Status

()

Bugzilla
Bugzilla-General
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Marques Johansson, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090223 Minefield/3.2a1pre GTB5
Build Identifier: 3.2.2

Use of uninitialized value in string ne at Bugzilla/Util.pm line 290.

Reproducible: Always
(Reporter)

Updated

9 years ago
Version: unspecified → 3.2.2

Comment 1

9 years ago
sub use_attachbase {
    my $attachbase = Bugzilla->params->{'attachment_base'};
    return ($attachbase ne ''
            && $attachbase ne Bugzilla->params->{'urlbase'}
            && $attachbase ne Bugzilla->params->{'sslbase'}) ? 1 : 0;
}

None of the parameters can be undefined. They are all created by checksetup.pl if they are missing (they are empty by default). So there must be something wrong with your installation. Try running checksetup.pl again, and make sure they are all defined in data/params.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Duplicate of this bug: 484498
You need to log in before you can comment on or make changes to this bug.