All users were logged out of Bugzilla on October 13th, 2018

infinite loop in makefiles.

RESOLVED FIXED

Status

P3
critical
RESOLVED FIXED
20 years ago
14 years ago

People

(Reporter: vdemarco, Assigned: briano)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
i types gmake -f mozilla/client.mk build

and i get:


ranlib libjsj.a
rm -f libjsj.so
gcc -shared -Wl,-h -Wl,libjsj.so -o libjsj.so ./jsj.o ./jsj_JSObject.o
./jsj_JavaArray.o ./jsj_JavaClass.o ./jsj_JavaMember.o ./jsj_JavaObject.o
./jsj_JavaPackage.o ./jsj_array.o ./jsj_class.o ./jsj_convert.o ./jsj_field.o
./jsj_hash.o ./jsj_method.o ./jsj_utils.o ./nsCLiveconnect.o
./nsCLiveconnectFactory.o
chmod +x libjsj.so
../../../config/./nsinstall -R -m 444 ./libjsj.a ../../../dist/./lib
../../../config/./nsinstall -R -m 555 ./libjsj.so ../../../dist/./lib
../../../config/./nsinstall -R -m 555 ./libjsj.so ../../../dist/./bin
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/liveconnect'
cd fdlibm; gmake libs
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Entering directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'
gmake[4]: Leaving directory
`/export/home/vdemarco/netscape_src/mozilla/obj-sparc-sun-solaris2.7/js/src/fdlibm'

** Build environment **
SunOS whatever 5.7 Generic sun4u sparc SUNW,Ultra-1
egcs-2.91.60
GNU Make version 3.74, by Richard Stallman and Roland McGrath.
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

20 years ago
I don't know for certain, but I think this might be a bug resulting
from a combination of the way the Makefile is written, and the new
default dependency system.

What happens if you try 'configure --enable-md=no' and then rebuild?
(Reporter)

Comment 2

20 years ago
Built with the following .mozconfig file

It has seemed to work:
###
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-@CONFIG_GUESS@

# Options for 'configure' (same as command-line options).
ac_add_options --enable-editor
ac_add_options --enable-new-clipboard
ac_add_options --enable-mailnews
ac_add_options --enable-oji
ac_add_options --disable-asserts
ac_add_options
--with-nspr=/export/home/vdemarco/netscape_src/obj-sparc-sun-solaris2.7/nspr
ac_add_options --enable-debug
ac_add_options --enable-md=no

I basically added the last line (ac_add_options --enable-md=no)as per
briano@netscape.com

The makefiles with the make dependencies automatically generated need to be
fixed. This is an okay work around.

Comment 3

20 years ago
What version of gmake do you have? Someone else reported that this problem went
away when they upgraded gmake.
(Reporter)

Comment 4

20 years ago
I have version 3.74 Should i upgrade

Comment 5

20 years ago
We haven't tracked this one down yet, but it does work with gmake 3.76.1. That's
the version most people seem to use. Do not upgrade to 3.77. That has a bug that
causes the same problem.
(Assignee)

Comment 6

20 years ago
This appears to be a bug in some versions of gmake having
to do with the wildcard function.  I'm experimenting with
different versions to see if I can come up with a simple
test that I can add to configure.
(Assignee)

Comment 7

20 years ago
*** Bug 4838 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

20 years ago
There is now a check for GNU make 3.77 in configure.  It will warn
the user that 3.77 has problems and tell them what they can do about
it.  The problem _may_ exist in 3.74 as well, but I have not verified
that.  Ideally, I want to create an actual test of the wildcard
function for configure to run on any version of gmake it finds, but
that will take time.  The main problem is that we still don't know
exactly what types/styles of wildcard usage causes the problem, and
we need to know that before a small test case can be developed.

I am marking this fixed, but I will continue to experiment when I
have spare time.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.