Closed Bug 479807 Opened 12 years ago Closed 12 years ago

<object> is completely reloaded from markup after it's style.display is toggled off an on

Categories

(Firefox :: General, defect)

x86
Windows Vista
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 90268

People

(Reporter: bugzilla, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; SLCC1; .NET CLR 2.0.50727; InfoPath.2; .NET CLR 3.5.21022; .NET CLR 3.5.30729; .NET CLR 3.0.30618)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6 (.NET CLR 3.5.30729)

If you dynamically set the style of an object tag to display="none", and then back to display="block|inline|<blank>", the plugin itself is re-instantiated as if the page just loaded. This causes any dynamic progress the plugin has made to be lost.

Reproducible: Always

Steps to Reproduce:
1. Declare an object on the page to a valid plugin.
2. Make some kind of dynamic change to the plugin, or allow the plugin to make behavioral progress.
3. Set the object's style.display to 'none', allow the javascript routine to return.
4. Set the object's style.display back to '' or 'inline' or 'block'.

Actual Results:  
The plugin reloads. How this manifests depends on the plugin. If it were in the process of an animation, for example, the animation will start over. If it were more like an application such as a game, the game restarts. Anything dynamically changed on the plugin via script will be lost.

Expected Results:  
The object shouldn't reload, it should simply become visible again.
Click the toggle display button twice, the 2nd click makes it visible again, showing the dynamic change being lost.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 90268
You need to log in before you can comment on or make changes to this bug.