Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Opening a browser window after starting with -mail uses session store

RESOLVED WORKSFORME

Status

SeaMonkey
Session Restore
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Ian Neal, Assigned: Misak Khachatryan)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
If you start with -mail and then open a browser window you get your stored session no matter what your prefs are set to.

Steps to reproduce.
1/ Make sure "Browser Startup" settings are not set to "Restore Previous Session"
2/ Open a few pages in various tabs
3/ Close SeaMonkey
4/ Start SeaMonkey with -mail command line flag
5/ Open a new browser window

Expected Results
1/ New window opens with settings as per pref

Actual Results
1/ New window opens with restored previous session
(Reporter)

Updated

9 years ago
Depends on: 36810
(Assignee)

Comment 1

9 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090225 NOT Firefox/2.0.0.20 SeaMonkey/2.0a3pre ID:20090225151534

I can't reproduce this on my Fedora 10. Which OS you are using ? Are you sure that SM doesn't crashing on exit ? Mine crashes very frequently on exit.
(Reporter)

Comment 2

9 years ago
Sorry, should have said, this is on Windows XP. Works fine on my Fedora 9 too.
OS: All → Windows XP
Hardware: All → x86
(Assignee)

Comment 3

9 years ago
I'll test it on vista tomorrow. However i can't reproduce it on wine too with today nightly :(
This is WFM with a SeaMonkey 1.9.1 build from a few days ago on Windows XP. Just wondering: How do you open the new browser window from MailNews?
(Assignee)

Comment 5

9 years ago
Ian, can you look at end of you sessionstore.json file in profile. There was bit right in the end like:

"session":{"state":"running","lastUpdate":1235666619455}}

If state is running as in example, then sessionstore restores your session, because it "crashed". Correctly exited Seamonkey should have "stopped" state. With this state, sessionstore looks to pref "browser.startup.page" what to do at startup.
(Reporter)

Comment 6

9 years ago
Just updated to 20090225002108 and no longer get the issue, as to what my previous version was I stupidly forgot to put it into the bug report, though I usually update twice a week. Anyway ->WFM
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: UI Design → Session Restore
QA Contact: ui-design → session.restore
You need to log in before you can comment on or make changes to this bug.