Update redirect for Japanese bookmarks extensions on amo

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
RESOLVED FIXED
9 years ago
3 years ago

People

(Reporter: kohei, Assigned: reed)

Tracking

({jp-critical})

Details

(Reporter)

Description

9 years ago
The URL of the Get Bookmark Add-ons link has been modified by Bug 471839.
Now it points https://addons.mozilla.org/@AB_CD@/firefox/bookmarks/

Please undo the change in order to retain the following redirect:
https://add-ons.mozilla.com/ja/firefox/bookmarks/
-> https://addons.mozilla.jp/firefox/extensions/bookmarks_and_history/

The redirect has been set by Bug 427323.
(Reporter)

Updated

9 years ago
Summary: Undo a bookmarks URL change caused by Bug 471839 → Undo a bookmark URL change caused by Bug 471839
(Assignee)

Comment 1

9 years ago
No, we shouldn't undo the change in the browser. It was purposely changed.

We'll be happy to change the rewrite rule to work with the new URL, though.
Assignee: nobody → server-ops
Component: General → Server Operations
Product: Firefox → mozilla.org
QA Contact: general → mrz
Target Milestone: Firefox 3.1b3 → ---
Version: unspecified → other

Comment 2

9 years ago
... what reed said.
Summary: Undo a bookmark URL change caused by Bug 471839 → Update redirect for Japanese bookmarks extensions on amo
(Reporter)

Comment 3

9 years ago
So please set the redirect from AMO:
https://addons.mozilla.org/ja/firefox/bookmarks/
-> https://addons.mozilla.jp/firefox/extensions/bookmarks_and_history/
Are you talking about add-ons.mozilla.org or addons.mozilla.org?  comment 0 and comment 3 are different
er, add-ons.mozilla.com.  I'm guessing this is the URL you want changed:

https://add-ons.mozilla.com/ja/firefox/bookmarks/

Comment 6

9 years ago
http://mxr.mozilla.org/mozilla-central/source/browser/locales/generic/profile/bookmarks.html.in?mark=11#11 is the entry point, i.e., https://addons.mozilla.org/ja/firefox/bookmarks/. Note that I'm replacing ja-JP-mac with ja for the replacing in the build, so there shouldn't be a need for ja-JP-mac redirects.
(Assignee)

Updated

9 years ago
Assignee: server-ops → reed
(Assignee)

Comment 7

9 years ago
Do you just want /ja/firefox/bookmarks/ redirected, or do you want all of /ja/firefox/ redirected? Currently, https://add-ons.mozilla.com/ja/firefox/* redirects to https://addons.mozilla.jp/firefox/...

RewriteRule ^/ja(?:-JP-mac)?/(firefox)(.*)$ https://addons.mozilla.jp/$1$2 [R=permanent,QSA,NE]
(Reporter)

Comment 8

9 years ago
(In reply to comment #7)
> Do you just want /ja/firefox/bookmarks/ redirected, or do you want all of
> /ja/firefox/ redirected? 

The /ja/firefox/ site itself should be kept. We'd like to have a redirect only for bookmarks.

> Currently, https://add-ons.mozilla.com/ja/firefox/* redirects to 
> https://addons.mozilla.jp/firefox/...
> 
> RewriteRule ^/ja(?:-JP-mac)?/(firefox)(.*)$ https://addons.mozilla.jp/$1$2
> [R=permanent,QSA,NE]

The add-ons.mozilla.com/ja/firefox URLs set as prefs (browser.dictionaries.download.url, extensions.getMoreExtensionsURL, etc.) has not been changed, so please keep the rewrite rule as is.
(Assignee)

Comment 9

9 years ago
Ok, redirect added.

(In reply to comment #8)
> The add-ons.mozilla.com/ja/firefox URLs set as prefs
> (browser.dictionaries.download.url, extensions.getMoreExtensionsURL, etc.) has
> not been changed, so please keep the rewrite rule as is.

That's changing soon, as soon as I have time to update a patch (hopefully for 3.1b4). :)
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.