incorrect display of certain Chinese characters

NEW
Unassigned

Status

()

Core
Layout: Text
9 years ago
9 years ago

People

(Reporter: Stephen Gourlay, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6

The link illustrates what should be displayed, and what is displayed. (In Explorer 7.0.5730.13 these are identical hence my conclusion it's a FF3 problem. I also get the same problem with FF3 under Linux Linpus Lite. Other characters are also incorrectly displayed. 
(In case the link does not carry over the search please do the following:
1) Go here: http://www.unicode.org/charts/unihansearch.html
2) Choose Mandarin from box 1
3) enter the following text in box 2: leng3
4) tick UTF-8 (though makes no difference).
5) click Lookup
6) On the results screen, the character under Unicode is a link - click this
7) you should see the link given above, showing the Unicode Standard display (which is correct), and Your Browser display (which is incorrect).

Reproducible: Always

Actual Results:  
see above

Expected Results:  
see above

see above

NB re severity (below) - your categories don't fit. It's major since certain characters in simplified Chinese (Mandarin) are not being displayed correctly. I'm only aware of this character and e.g. lian2 (U+601C - the Unihan number). There may be others - please ask fluent Chinese readers to check.
(Reporter)

Updated

9 years ago
Hardware: All → x86
Version: unspecified → 3.0 Branch
I can reproduce the described problem on Windows XP, consistent in all versions I tried. Opera does it also wrong but displays still another variant.
IE7 and Google Chrome do it both correctly.
Status: UNCONFIRMED → NEW
Component: General → Layout: Text
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
Version: 3.0 Branch → Trunk
You need to log in before you can comment on or make changes to this bug.