Last Comment Bug 4800 - Win95-J: Apprunner crashes when loading some CJK pages
: Win95-J: Apprunner crashes when loading some CJK pages
Status: VERIFIED FIXED
QA BLOCKER:fixed in local tree; need ...
:
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: x86 Windows 95
: P1 critical (vote)
: M5
Assigned To: Erik van der Poel
: Teruko Kobayashi
: Makoto Kato [:m_kato]
Mentors:
http://home.netscape.com/ko
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-08 14:51 PDT by Teruko Kobayashi
Modified: 2005-03-17 13:34 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Teruko Kobayashi 1999-04-08 14:51:10 PDT
I tested 4-8-10-99 Win32 build under Winnt4.0J and Windows 95J.

This happens under Windows 95J.

When I go to the Korean page http://home.netscape.com/ko and both Simplified Chinese and Traditional Chinese
page http://home.netscape.com/zh, Apprunner will crash.

Under Winnt 4.0J, it does not crash.
Comment 1 Teruko Kobayashi 1999-04-08 15:21:59 PDT
I tested these page under Win98J.  Apprunner does not crash.
Comment 2 Teruko Kobayashi 1999-04-08 16:16:59 PDT
Under Windows 95J, Apprunner will crash when loading some Japanese pages.
 http://babel/tests/browser/bft/sjis/bft_browser_form_sjis.html
or other HTML test cases under http://babel/tests/browser/html/new_html40/sjis/ directory.
but Apprunner does not crash when loading http://home.netscape.com/ja page.

Under Windows 95US and Windows 95Korean, Apprunner does not crash in Korean and Chinese Netscape
home pages.
Comment 3 Katsuhiko Momoi 1999-04-09 14:29:59 PDT
Here's one workaround for this problem.

For Japanese display only, you can download the prefs.js file from here:

http://rocknroll/users/momoi/publish/

and have Bitstream Cyberbit font on your system.
You should not modify or comment out the default charset line:

 user_pref("intl.character_set", 260);

Plus of course the font settings. This takes care of the following problems:

1. Proble pages like the follolwing will load without an error and
   displays OK.

   http://home.netscape.com/ja
   http://Kaze:8000/jis.html
   http://kaze:8000/sjis.html
   http://kaze:8000/euc.html

This probably means that Korean and Chinese display will not
work all that well.

2.Windows-native fonts will not let you display Japanese. Bitstream
  font setting in the prefs,js file makes it OK.
Comment 4 Erik van der Poel 1999-04-10 16:40:59 PDT
OK, I tracked this down. If you call GetTextExtentPoint32W on the character
0xB7 in the Times font on Japanese Windows 95, you crash. It also crashes if
the character is 0xFFFD.

Unbelievable. Any suggestions to workaround this?
Comment 5 Erik van der Poel 1999-04-11 22:34:59 PDT
I wrote a tiny program to check this, and it does indeed crash on 0xB7, but not
on 0xFFFD. However, Mozilla does crash on 0xFFFD sometimes.

I also tried GetTextExtentPoint32A on 0xB7 on Japanese Windows 95, and it did
not crash.

Sigh. Does this mean that we need to convert from Unicode to the various code
pages before calling the Windows APIs on Windows 95?
Comment 6 Teruko Kobayashi 1999-04-28 18:23:59 PDT
This need to be reopened since 4810 is reopened.
Comment 7 Erik van der Poel 1999-04-29 22:23:59 PDT
I found the bug, and fixed it in my local tree.
Comment 8 leger 1999-04-29 23:38:59 PDT
Putting on QA Blocker List.
Comment 9 Teruko Kobayashi 1999-05-03 12:54:59 PDT
I verified this in Win32 5-03-08 build under Win95J.

Note You need to log in before you can comment on or make changes to this bug.