Firefox remained offline after crash

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: Paula, Unassigned)

Tracking

3.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008032600 SUSE/2.9.95-25.1 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008032600 SUSE/2.9.95-25.1 Firefox/3.0b5

[?1034h(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb64686d0 (LWP 2773)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb7d3c0ef in ?? () from /usr/lib/libkio.so.5
#7  0xb7d3db75 in KDirModel::qt_metacall () from /usr/lib/libkio.so.5
#8  0xb75933fa in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#9  0xb7593972 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#10 0xb7d28563 in KDirLister::newItems () from /usr/lib/libkio.so.5
#11 0xb7d294aa in KDirLister::Private::emitItems () from /usr/lib/libkio.so.5
#12 0xb7d2aef1 in ?? () from /usr/lib/libkio.so.5
#13 0xb7d36193 in ?? () from /usr/lib/libkio.so.5
#14 0xb75933fa in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#15 0xb7593972 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#16 0xb7d06469 in KIO::ListJob::entries () from /usr/lib/libkio.so.5
#17 0xb7d14ee3 in ?? () from /usr/lib/libkio.so.5
#18 0xb7d14fe0 in KIO::ListJob::qt_metacall () from /usr/lib/libkio.so.5
#19 0xb75933fa in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#20 0xb7593972 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#21 0xb7db4283 in KIO::SlaveInterface::listEntries () from /usr/lib/libkio.so.5
#22 0xb7db6d99 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.5
#23 0xb7db4bd7 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.5
#24 0xb7da8660 in KIO::Slave::gotInput () from /usr/lib/libkio.so.5
#25 0xb7da89d3 in KIO::Slave::qt_metacall () from /usr/lib/libkio.so.5
#26 0xb75933fa in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#27 0xb7593972 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#28 0xb7ce35a7 in KIO::Connection::readyRead () from /usr/lib/libkio.so.5
#29 0xb7ce4fe2 in ?? () from /usr/lib/libkio.so.5
#30 0xb7ce5636 in KIO::Connection::qt_metacall () from /usr/lib/libkio.so.5
#31 0xb758e33b in QMetaCallEvent::placeMetaCall () from /usr/lib/libQtCore.so.4
#32 0xb758fed1 in QObject::event () from /usr/lib/libQtCore.so.4
#33 0xb6acbecc in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#34 0xb6ad231e in QApplication::notify () from /usr/lib/libQtGui.so.4
#35 0xb7afb36d in KApplication::notify () from /usr/lib/libkdeui.so.5
#36 0xb7581b51 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#37 0xb7582411 in QCoreApplicationPrivate::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#38 0xb75aa32a in QEventDispatcherUNIX::processEvents ()
   from /usr/lib/libQtCore.so.4
#39 0xb6b560a2 in ?? () from /usr/lib/libQtGui.so.4
#40 0xb75802ca in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#41 0xb758048a in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#42 0xb758266d in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#43 0xb6acbd47 in QApplication::exec () from /usr/lib/libQtGui.so.4
#44 0xb7fa1b43 in kdemain () from /usr/lib/libkdeinit4_konqueror.so
#45 0x080487c2 in _start ()
#0  0xffffe430 in __kernel_vsyscall ()

I even restarted the computer and it was still saying that Firefox (3 Beta 5) was offline. In fact I couldn't get online to report this bug until I inserted "The Ultimate Boot Disk" and had it boot the hard drive.

Reproducible: Sometimes

Steps to Reproduce:
1. I'm new to this bug reporting and don't know how to reproduce or what that means.
2.
3.
Actual Results:  
The browser continued to be offline after I had clicked on the browser buttons for both Firefox and the operating system I'm using (openSUSE) which is a Linux system. 

Expected Results:  
I hoped that the buttons would give me a clue on how to access my browser, but even that information was unavailable because of the offline browser.

I was online for about a minute and my computer went off while I was trying to check my email. When I got the computer logged back on it gave me the message that my Firefox was offline. I clicked on the icons on my browser for Firefox and OpenSUSE, the Linux system I used and still got the message that Firefox was in the offline mode. I logged off and restarted the computer but I still had that message as well as the KDE bug message which was a signal 11. I had to insert my "Ultimate Boot CD" and push "First Hard Drive" to be able to access Firefox (3 Beta 5) to get online to report the bug.
First, Firefox 3.0b5 is very old. You should at least use 3.0.6, or a nightly build would be better.
http://www.mozilla.com/en-US/firefox/all.html
ftp://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-1.9.1/
ftp://ftp.mozilla.org/pub/firefox/nightly/latest-trunk/
Any of those will work.
Steps to reproduce means what caused this issue to occur.
You can read http://quality.mozilla.org/bug-writing-guidelines after installing a new version for more help.

I think the new summary explains the issue?
Summary: I was unable to get online since my Firefox was in the "offline mode". The crash was the result of a "signal 11" → Firefox remained offline after crash
Version: unspecified → 3.0 Branch

Comment 2

9 years ago
err, you've provided a crash stack for konqueror which is a competitor to firefox.

i think you should complain to your vendor (suse) using their bug reporting system, that might be https://bugzilla.novell.com/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.