cannot cancel a bookmark deletion in bookmarks menu or toolbar

RESOLVED DUPLICATE of bug 381770

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED DUPLICATE of bug 381770
9 years ago
9 years ago

People

(Reporter: nico, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2

If a bookmark is accidentally deleted, for instance by clicking on "Delete" option instead of "Properties" in its context menu in the bookmarks menu or bookmarks toolbar, there is no way to cancel it.

The only way to retrieve is is to open the bookmarks sidebar or the library (Bookmarks menu > Organize Bookmarks…) and then to hit the Ctrl+Z shortcut (or Organize > Cancel in the Library).

Reproducible: Always

Steps to Reproduce:
1. Bookmark a page in the Bookmarks Menu
2. Open the Bookmarks menu
3. Right-click on the created bookmark and select "Delete"
4. Try to retrieve it.

-- or --

1. Bookmark a page in the Bookmarks Toolbar
2. Display the Bookmarks Toolbar if needed
3. Right-click on the created bookmark and select "Delete"
4. Try to retrieve it.
Actual Results:  
There is no way to retrieve it without opening the Library or the Sidebar.

Expected Results:  
Ctrl+Z shortcut in the menu or a "Cancel" option in the context menu should allow to cancel the deletion.

Prompting the user when he tries to delete a bookmark
(Reporter)

Updated

9 years ago
Component: General → Bookmarks & History
Version: unspecified → Trunk

Comment 1

9 years ago
Either there should be a way to undo the deletion, or the bookmark could be
sent to a trash folder, but I agree deleting without even prompting or giving a
way to undo is problematic.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 381770
You need to log in before you can comment on or make changes to this bug.