Fennec creates bookmarks when the user marks the page as a favorite

VERIFIED INVALID

Status

VERIFIED INVALID
10 years ago
9 years ago

People

(Reporter: jaakko.viitanen, Unassigned)

Tracking

Trunk
x86
Linux

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Build Identifier: Fennec/1.0a3pre

Fennec should mark pages as favorite when the star button is pressed but currently Fennec creates bookmarks when the button is pressed. 

Reproducible: Always

Steps to Reproduce:
1. Navigate to any page
2. Drag control strip to view
3. Tap star icon
Actual Results:  
Fennec creates a bookmark 

Expected Results:  
Fennec tags page as favorite

Also the star button needs an additional state. Currently it has 3 states: normal, pressed and favorite. it needs the pressed favorite as well to alleviate user confusion.
Why is the distinction important? What do you mean by "favorite"?
(Reporter)

Comment 2

10 years ago
to my knowledge the "star" icon creates the favorite tag that is then used in the sorting of awesomebar results. Favorite pages then show up in the awesomebar results as favorite pages and they are prioritized and not forgotten even if the user doesn't visit the page often. 

Bookmarks on the other hand are pages that the user visits often and can be customized and managed by the user (editing name, filing under folders ect.)
Ah, I see. That's not quite how it is implemented, though. "Starred" is equivalent to "bookmarked", and tags are not related to the star at all. We do prioritized bookmarked pages in general. This is the same model that's used in Firefox, as far as I know.
After talking to the Firefox places devs, the Fennec behavior is correct. Marking invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Updated

10 years ago
Status: RESOLVED → VERIFIED

Comment 5

9 years ago
sorry for bug spam.
Many of the bugs which are marked invalid, I see comments telling it occurred in one version or other. But later it was fixed due to 1) by backingout the patch which made regression or 2) by fixing some other bug.
So if we can identify the bug/patch/reason then we should state that and mark those as FIXED. If not mark as WORKSFORME in that case.
Component: General → Bookmarks
You need to log in before you can comment on or make changes to this bug.