the big table on the YAHOO page never showed up

VERIFIED FIXED

Status

()

Core
Layout: Tables
P3
major
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Chris Jensen, Assigned: karnaze (gone))

Tracking

({testcase, top100})

Trunk
x86
All
testcase, top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm-] a=buster, r=attinasi, URL)

Attachments

(5 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14-5.0 i686; en-US; m17) Gecko/20000807
BuildID:    20000807121

the big table on the page never showed up... the table is probably 200k large

Reproducible: Always
Steps to Reproduce:
1.enter in the url and go to the page
2.
3.

Actual Results:  same thing

Expected Results:  rendered the page properly

Comment 1

18 years ago
Confirmed 2000080804 Linux
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
Chaning OS to all as it also happens under WinNT 2000080714. The html-source can
be viewed with View : Page source. So it is really a table rendering problem.
OS: Linux → All

Comment 3

18 years ago
true-wildcat@rocketmail.com - makingtest, but don't have permissions yet...

Comment 4

18 years ago
Created attachment 12685 [details]
this is a testcase

Comment 5

18 years ago
the table shows up if you take out the font or caption tags

Comment 6

18 years ago
This is really weird. The placement of the FONT tag makes a difference if the 
table is displayed or not. It is incorrectly placed in the test case. Putting 
the FONT tag on the inside of the CAPTION does cause the table to be rendered.

Looking at a dump of the content model, the FONT tag is placed outside the TABLE 
and the row and cell are properly created. However, then looking at the frame 
dump, an empty table is created. No frames for the row or cell are created. 

Comment 7

18 years ago
Using the 8/10 testcase. It is illegal for FONT to contain CAPTION per the 
Transitional DTD. I'm not sure how this should be rendered in this case, but I 
imagine the FONT tag should be ignored and the text rendered.

Updated

18 years ago
Keywords: testcase

Comment 8

18 years ago
Created attachment 17519 [details]
more complete test case

Comment 9

18 years ago
Attaching another testcase and nominating this for rtm. FONT element cannot 
contain CAPTION so this HTML is illegal. However, by enclosing CAPTION in FONT, 
the entire table below it is wiped out on this Yahoo page: 
http://store.yahoo.com/lib/thechipmerchant/pricelist.html
which consists of about 500 listed items.
Keywords: rtm

Comment 10

18 years ago
Created attachment 18008 [details]
another testcase
(Assignee)

Comment 11

18 years ago
Adding [rtm need info].
Status: NEW → ASSIGNED
Whiteboard: [rtm need info]
(Assignee)

Comment 12

18 years ago
Created attachment 18044 [details] [diff] [review]
patch to fix the bug
(Assignee)

Comment 13

18 years ago
Created attachment 18046 [details] [diff] [review]
the correct patch (ignore the last one)
(Assignee)

Comment 14

18 years ago
Marking rtm+.
Whiteboard: [rtm need info] → [rtm+] a=buster, r=attinasi

Comment 15

18 years ago
This seems like a pretty big fix in a pretty central area of the code for this
point in the RTM cycle. Can we solicit Yahoo to fix their content? Marking [rtm
need info] and cc'ing ekrock.
Whiteboard: [rtm+] a=buster, r=attinasi → [rtm need info] a=buster, r=attinasi

Updated

18 years ago
Summary: the big table on the page never showed up → the big table on the YAHOO page never showed up

Comment 16

18 years ago
PDT marking [rtm-]. Big patch; no time to shake it out.
Whiteboard: [rtm need info] a=buster, r=attinasi → [rtm-] a=buster, r=attinasi
Marking top100 as this is Yahoo and evangwanted since we'd like to evangelize
Yahoo to fix their markup (which is invalid) to avoid triggering the bug in the
first place.
Keywords: evangwanted, top100
(Assignee)

Comment 18

18 years ago
The patch has been checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 19

18 years ago
Incidently, I could be mistaken, but I believe this bug may also have been the
reason I never saw some of the content on www.redhat.com.

Updated

18 years ago
Keywords: evangwanted

Comment 20

17 years ago
QA contact update
QA Contact: chrisd → amar

Comment 21

17 years ago
 The given test case and URL looks good.. Marking verified on 
2001-07-27-00-0.9.2 build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.